Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Trucks & Trailers
Reload this Page >

Mazda CX-9 traction control system (TCS) shutoff not working

Notices

Mazda CX-9 traction control system (TCS) shutoff not working

Old 02-16-2015, 06:31 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Mar 2010
Location: Sharon, MA & Falmouth, Cape Cod
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default Mazda CX-9 traction control system (TCS) shutoff not working

So we got dumped on with snow yesterday and I was trying to get my wife's cx-9 out of the driveway but every time I pushed the gas the traction control system would kick in. I tried turning it off by pressing the TCS off button but it did nothing. Anyone else run into this issue?

What am I doing wrong? How can I turn TCS off so I can power through the ice/snow?
Old 02-16-2015, 07:07 AM
  #2  
Senior Member
 
Join Date: Nov 2010
Location: OBX
Posts: 2,801
Likes: 0
Received 166 Likes on 109 Posts
Default

You can pull the abs/tc fuse to get free, and then put the fuse back in once on better ground.
Old 02-16-2015, 07:10 AM
  #3  
Senior Member
Thread Starter
 
Join Date: Mar 2010
Location: Sharon, MA & Falmouth, Cape Cod
Posts: 306
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by stowaway View Post
You can pull the abs/tc fuse to get free, and then put the fuse back in once on better ground.
Will give that a go. Thanks. Going to take into dealer later today for them to diagnose. Any idea why the switch isn't working?
Old 02-16-2015, 07:26 AM
  #4  
Senior Member
 
Join Date: Nov 2010
Location: OBX
Posts: 2,801
Likes: 0
Received 166 Likes on 109 Posts
Default

My understanding is stupidly oversensitive restrictions that turn it back on with just modest wheel speed (around 15mph I think) keeps you from getting out of the situation.

Or the switch is broken.
Old 02-16-2015, 07:47 AM
  #5  
Senior MemberCaptains Club Member
 
Join Date: Jul 2006
Posts: 2,417
Received 90 Likes on 65 Posts
Default

i think to turn it off you need to hold down the button for almost 30 seconds.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.