Go Back  The Hull Truth - Boating and Fishing Forum > PRODUCTS > Shurhold Industries
Reload this Page >

GFI plug wonít work, cleaning pads

Notices

GFI plug wonít work, cleaning pads

Old 05-19-2018, 04:18 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2008
Posts: 537
Default GFI plug wonít work, cleaning pads

first, the GFI plug on my polisher is acting up and it seems like it isnít getting a connection unless we tape the two connections together tightly and even then itís a big pain. Would you have a replacement you could send me. I love the polisher!

second, I have a box of used pads and was wondering if there is any way to clean them so they are not hard?
fshnoc is offline  
Old 05-21-2018, 07:57 AM
  #2  
Senior Member
 
Join Date: Apr 2015
Location: Stuart, Florida
Posts: 500
Default

Originally Posted by fshnoc View Post
first, the GFI plug on my polisher is acting up and it seems like it isnít getting a connection unless we tape the two connections together tightly and even then itís a big pain. Would you have a replacement you could send me. I love the polisher!

second, I have a box of used pads and was wondering if there is any way to clean them so they are not hard?
Send me a PM with your address and I'll ship you out a new GFI plug. They will eventually go bad so we are happy to replace that for you. As far as cleaning your pads, we actually have a chemical for that. Check out this old video we filmed on the subject. It's a bit dated, but the info is all there.

https://shurhold.com/article/clean-n...-buffing-pads/
CaptSamShurhold is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread