Notices

Suzuki DF350 port engine not turning over

Old 07-15-2020, 12:33 PM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2020
Posts: 14
Received 0 Likes on 0 Posts
Default Suzuki DF350 port engine not turning over

Thanks ahead of time for any feedback or recommendations. So I ran an offshore trip a couple days ago and on our way in about 10miles from the beach the port engine started sputtering and conked out and wouldn’t restart and we got a “low fuel” alarm. Also, on the C10’s gauge all of the port engine info went away for some reason. Got the boat back to the dock and filled with fuel and tried to start again and it just sputters but won’t turn over. Before this trip we had just replaced all of the fuel filters and spark plugs. Today I went down to the boat and checked the fuel pressure with a pressure gauge and the psi was good so that tells me the engine is getting fuel. I also checked the fuses in the engine and they were all fine and checked the voltage on the battery’s which were brand new a couple weeks ago. I am completely stumped. Anywhere else I should be looking?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.