Notices

Df350 trims on its own.

Old 07-05-2020, 07:28 AM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2012
Posts: 558
Received 196 Likes on 117 Posts
Default Df350 trims on its own.

2019 df 350s. Port will trim with the key off with the button on the motor. Turn the key on and it trims down all the way by itself. Unhooked the button on the motor. No difference. Unhooked the start stop harness and it disables both motors tilt and trim but when you turn key on it trims down by itself again. Any quick ideas? Thanks Ross.
Old 07-06-2020, 05:23 AM
  #2  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 2,190
Received 341 Likes on 188 Posts
Default

It sounds like you have a bad trim switch on binnacle or start/stop panel. The trim all runs through the start/stop panel so you need to isolate the binnacle as well to see if it follows.
Old 07-06-2020, 08:08 AM
  #3  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2012
Posts: 558
Received 196 Likes on 117 Posts
Default

If it was the binnacle wouldn’t it affect both motors?

I’m going to unhook the start stop pad again to confirm that it still does it with that unhooked.
Old 07-06-2020, 08:16 AM
  #4  
Senior Member
 
Join Date: Jan 2011
Location: Hampstead, NC
Posts: 1,371
Received 355 Likes on 191 Posts
Default

Originally Posted by Rferrell View Post
If it was the binnacle wouldn’t it affect both motors?

I’m going to unhook the start stop pad again to confirm that it still does it with that unhooked.
No I had this problem out the gate with new 150s it was a relay in the binnacle
Old 07-06-2020, 10:08 AM
  #5  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2012
Posts: 558
Received 196 Likes on 117 Posts
Default

Ok. So after unhooking everything from binnacle and start stop pad. It still goes down on own after turning key on.

With everything hooked up I can pause the motor from going down by pressing the trim up button on the binnacle or the start stop pad.
Old 07-06-2020, 10:24 AM
  #6  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 2,190
Received 341 Likes on 188 Posts
Default

Originally Posted by Rferrell View Post
Ok. So after unhooking everything from binnacle and start stop pad. It still goes down on own after turning key on.

With everything hooked up I can pause the motor from going down by pressing the trim up button on the binnacle or the start stop pad.
I would look at the main harness plugs, square brown plugs at transom area and under console, you might have some corrosion causing a short. With the key on you are energizing the trim down wire.
Old 07-06-2020, 05:00 PM
  #7  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2012
Posts: 558
Received 196 Likes on 117 Posts
Default

Originally Posted by Outboard Specialties View Post
I would look at the main harness plugs, square brown plugs at transom area and under console, you might have some corrosion causing a short. With the key on you are energizing the trim down wire.

100% seems to be the problem. You can see the corrosion in the picture. I cleaned with a little wd-40 and will scrap the corrosion off. Do I need to put a little electrical grease in the plug?

Thanks for the help. With a little plug and unplug a few times it seems to have cleaned it enough to work properly.
Old 07-06-2020, 05:00 PM
  #8  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2012
Posts: 558
Received 196 Likes on 117 Posts
Default


Old 07-07-2020, 05:48 AM
  #9  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 2,190
Received 341 Likes on 188 Posts
Default

There you go, glad you found it.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.