Notices

DF350 Fuel gauge Issue

Old 07-13-2019, 02:30 PM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Mar 2007
Location: Sarasota, FL
Posts: 84
Default DF350 Fuel gauge Issue

So I am running a DF350 that is fed by 3 tanks, 2 x 55 saddles and a 110 Center. Today running across Tampa bay, I had my fuel selector switch set to ALL Tanks. I can switch between Center, Port and Starboard, and All. All of my fuel percentages showed approx. 45%. Out of the blue, my port gauge drops to 0% and starts flashing red. Center and Starboard both stayed and slowly decreased as normal? This is the second time this has happened. The first time I just thought someone had siphoned all the gas out of my tank. Any idea what this could possibly be.
Bad Fuel sender ?? Boat is a 2018.

Thanks for any advice

racerman is offline  
Old Yesterday, 05:45 AM
  #2  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 1,949
Default

Sounds like either a bad fuel sender, connection or fluid level sensor. The sender is in the fuel tank while the fluid level sensor should be in the console and goes in between the fuel sender wires and the nmea2000 network for the digital gauges. This fluid sensor converts the analog fuel sender signal to a nmea2000 format that the gauge can read. You can check the fuel sender by taking the 2 wires that come off of it and touch them together, if the gauges shows full then the wiring and fluid sensor is good and you need to change the fuel sender.
Outboard Specialties is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread