Notices

05 DF225 WOT issue

Old 06-14-2019, 05:37 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Oct 2008
Location:
Posts: 112
Default 05 DF225 WOT issue

I have a question regarding the the WOT position. I achieve maximum RPMs but still have and an inch or tow of throttle lever left. Moving the throttle those last 2 inches of travel results in no additional RPMs of change in motor noise. It appears to be doing nothing. I have checked to the best of my understanding that the cam alignment mark is in the center of the cam pin as shown in the manual. Also The neutral stop and wide open stops on the throttle body and/or air intake are correct. Also butterfly is in fully open position at full open throttle. Is there anything else I could be missing? I have checked the fuel line from the the tank pickup to the low pressure fuel filter. All filters have been replaced including VST screen. Anti siphon valve was removed also. Possible fuel pump issue or faulty TPS? Not showing any codes or alarms. Just seems like I'm leaving some performance on the table. Other than this issue the motor runs great.
linesider04 is offline  
Old 06-14-2019, 10:24 AM
  #2  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 1,925
Default

Its possible you have a stretched out throttle cable or just out of adjustment. But if all else looks good and motor runs fine otherwise and you are getting proper wot rpms(rated 5500-6000rpm) then there is nothing wrong and no reason to keep digging into it. It might simply be play in the cable and linkages.
Outboard Specialties is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread