Notices
Like Tree1Likes
  • 1 Post By Outboard Specialties

PTT problems 2014 300s

Old 06-05-2019, 04:44 PM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jan 2013
Posts: 162
Default PTT problems 2014 300s

So I have Starboard and center not tilting up or down. I can hear the clicking of the relay but no motor sound. I pulled the harness and connected a meter to the blue/green and it reads over 13v when I activate the up/down on side of engine.

Brand new batteries 2 months ago. All reading over 13v when separated and tested individually. The starboard has obvious leaking of fluid when I lowered boat in water and center barely made it to up postition then gave out. Can’t tell any leakage and when I opened the fill drain cap fluid came out.

Any sugestions to what it might be? Bad pump motors? Both within a day of each other? Crazier things have happened for sure....

I can send video of sound but there is no motor sound just the clicking of the relay.

Oh and getting to that harness is a pain in the butt.... needed my 4 year old sons hands

Last edited by therumline; 06-05-2019 at 04:54 PM.
therumline is offline  
Old 06-06-2019, 11:25 AM
  #2  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 1,925
Default

It sounds like 2 bad trim motors from your description. Try putting 12 volts directly to those blue and green wires and see if motor runs, otherwise they are bad. Make sure wires didn't get pinched or cut up from a hook, fish etc..., I've seen that happen.
Definitely a tight fit in there.
Outboard Specialties is offline  
Old 06-07-2019, 04:12 PM
  #3  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jan 2013
Posts: 162
Default

Yep..... I got nothing when hooked up to 12v directly.

how on earth do you get that back screw out to remove PTT motor?
if I unbolt the whole assembly will it give me enough room to get something back there to get that last screw?
Any ideas besides removing motor mount would be much appreciated!
therumline is offline  
Old 06-08-2019, 09:02 AM
  #4  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 1,925
Default

You need to unbolt the assy and slide out some or sometimes you have to remove the clamp bracket to get to it. Can be tough.
Outboard Specialties is offline  
Old 06-10-2019, 08:56 AM
  #5  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jan 2013
Posts: 162
Default

Thanks for your replies its greatly appreciated by all. Is there a part number for the PTT seal kit? or do I need to order seals individually? Need to swap out new for new ones on the starboard and might as well the center.
therumline is offline  
Old 06-11-2019, 04:51 AM
  #6  
Senior MemberCaptains Club Member
THT sponsor
 
Outboard Specialties's Avatar
 
Join Date: Jan 2007
Location: Pompano Beach, FL
Posts: 1,925
Default

seals come individually as part of the cap that unthreads. We have everything in stock, you can call the shop at 954-942-9898 and ask for Jackie in parts
therumline likes this.
Outboard Specialties is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread