Notices

Tuna_Maniac Tuna_Maniac is offline

Senior Member

About Me

  • About Tuna_Maniac
    Biography
    CPT in the US Army
    Location
    Smithfield, NC
    Interests
    Fishing, boating, trucks, 4 wheelers, hunting, and beer.
    Occupation
    Army Officer
  • Signature

    2011 Dodge Ram 2500 4x4 Cummins
    2005 Hydra-Sports 2500CC w/ twin Yamaha F250

Statistics

Total Posts
Albums
Visitor Messages
Total Likes
General Information
  • Last Activity: 06-20-2020 11:56 AM
  • Join Date: 10-24-2011
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. 01-31-2017 06:12 PM
    I had the exact same problem. Exactly one year ago I contacted raymarine and set up a repair order. Shipped them my dsm300 with an explanation of the problem with instructions to call me with an estimate. In less than two weeks a brand new 370 unit shows up with a brief note that they found defective connectors. There was no charge! New unit was plug and play with a slight performance improvement but most importantly no more frustrating Lost Connection. Give them a call, send it, and see what happens. Worth a try.
  2. 09-10-2016 07:46 PM
    please send me your email address. I have 5 boat cover options for you. Thanks,

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.