Notices

Moonlighter475 Moonlighter475 is offline

Senior Member

Visitor Messages

Showing Visitor Messages 1 to 7 of 7
  1. PiranhaPR
    07-08-2018 05:54 AM
    Moonlighter475,
    I have 2, 2007 DF300's with 4" SMIS gauges with the blue connectors. I've had off and on issues with the gauges so I"m looking to make a change.
    Will two of the Suzuki OEM AU multi function gauges work for my application if I hook up 1 gauge to each engine and connect both to the NEMA 2000 network?
    The other instruments I have in the system are Simrad 16" and 12" MFD displays.
    Just wanted to make sure the gauges would work for my application before purchasing.
    It's my understanding that the C10 gauges are not compatible with pre-2010 engines.
    Thanks for any advice you can provide.


  2. ozmako
    03-01-2018 10:56 PM
    Hi Grant
    Thanks for your advice
    It turns out the ECU data cable is faulty
    Do you know where I can source one around 8.0 length it is the large plug Suzuki DF 175 2007 2008
    Thanks in advance
    Regards Dennis Exmouth W.A.
  3. jpbatliner
    01-18-2017 08:01 PM
    Hello Moonlighter. I am running twin 2007 DF175s that had digital gauges from the factory. I had one interface cable go bad several seasons ago and I replaced it but it has not had accurate fuel flow since. Could you please PM me the 2.3 version of the firmware so that I can update my interface cable to see if it will resolve my issue? (You helped me the other day get in contact with international marine and they are sending me a interface cable with 2.3 on it already for the other engine which just had it's interface cable go bad last month.) Hopefully I will have both engines reporting accurately soon!

    Thank you for all the information you have made available on this process.

    Jason Batliner
  4. ServiXe Detailing
    08-13-2016 06:05 AM
    Got it thank you!
  5. ServiXe Detailing
    08-12-2016 09:36 AM
    Hello

    How do I display suzuki 200hp 2016 engine hours on my simrad ? I can see all other data but cant figure the total hrs. THANK YOU for all the help!

    JOLO
  6. javy
    01-13-2016 04:11 PM
    Hello moonlighter.
    I just received my plugs from eastern beaver and i am doing mi plug. I am not clear still about the wire placement in the plug. Its a 2005 suzuki df200. I am going from the round plug to the square one. I think i just need to use 3 out of th e four wires. Can you help me with this. Thanks in advance.
  7. kiwiflya
    11-29-2015 09:25 PM
    Hi there, wondering id you could post solution to the problem of rev limiting at 4200rpm after installing nmea networking. I seem to have this problem but a restart solves its.

About Me

  • About Moonlighter475
    Location
    Australia
  • Signature
    Note to self: Dont argue with idiots, it just beings you down to their level where they beat you with experience.... and, you can't fix stupid

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 04:06 AM
  • Join Date: 11-03-2009
  • Referrals: 1