Notices

diad diad is offline

Admirals Club

About Me

  • About diad
    Location
    Kent Island, MD

Statistics

Total Posts
Visitor Messages
Total Likes
General Information
  • Last Activity: Today 05:59 AM
  • Join Date: 05-03-2009
  • Referrals: 0

Visitor Messages

Showing Visitor Messages 1 to 4 of 4
  1. 07-15-2019 04:50 AM
    Hey hows it going? We are going out of west OC tomorrow. If you don't mind can you let me know how you did? We don't make it out very often so its always a crap shoot and if you can lend any advice based on how your trip was today it would be greatly appreciated. Thank you and tight lines!
  2. 06-05-2017 06:02 PM
    I had the same problem. My first bilge pump lasted 11 years. Then it started making noises, but still worked. Ordered same pump, by now instead of US made, it was mexico made. I went thru four pumps, within one year. Each was failing due to the electronics.


    I opened them up, and bypassed the electronics.

    I then used them with an external float system. I prefer the electronic float kind. You can merely just use the manual wire and then split it off to a float and the manual switch.

    Good luck.

    Chris Elkins
    ps. Make sure your connections are protected. That means up high in the bilge where salt water will likely be less of a problem. Plus heat shrink connections. I like to run the bilge pump to a block that is away from the bilge and make connections there. Spray the heck out of that block with anti corrosion. Check it frequently. Good luck.
  3. 12-07-2016 05:19 PM
    hey bud , your private message box is full
  4. 07-20-2012 08:20 AM
    I amy be interested in the 24. Can you email me some pics and details trace@cfl.rr.com

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.