Go Back  The Hull Truth - Boating and Fishing Forum > Members List
Reload this Page >

Aquasportfisher's Profile

Notices

Aquasportfisher Aquasportfisher is offline

Admirals Club

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. GBKnight
    02-12-2013 04:18 PM
    Hi Again...GBKnight here. I need to send you a few pictures for your review of the parts I have questions on. I dont know how to use this forum very well, so can I send them to an email address? I can be reached at

    hutch.gwynn@gmail.com

    I believe I have tracked my 2-cycle oil leak down to the oil pre-mix injector pump being the problem. I have the Yamaha 130, manufactured around 1988. Is this something I can rebuild, or should I buy a complete replacement? how often do they go bad to where they cause an oil leak? thanks for the help! Also... I have pictures of a hose that is extenal of the engine that is disconnected. I wonder if you can identify it. it is completely disconnected, and appears to have factory paint sprayed on it, so I think its something Yamaha intends to have connected.

    Thanks for any help!
  2. Centurytreasure
    02-09-2013 08:24 AM
    I just purchased a 1998 century 2600 walk around and noticed one of your posts that you may have wiring drawings for a century. do you have them electronic and could i get a copy or do you know where i can find them?

About Me

  • About Aquasportfisher
    Biography
    Lifelong fisherman and boat owner
    Location
    Port Fierce, FL
    Interests
    Fishing, boating
    Occupation
    Wynne Bldg. Corp
  • Signature
    Current fleet
    '03 Century 2600 CC twin Yami F225's-sold
    '87 Aquasport Osprey 200 Yami F115
    '97 NV 16 Yami 50

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: Today 06:29 PM
  • Join Date: 04-21-2012
  • Referrals: 0

Friends

Showing Friends 1 to 1 of 1