Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Reload this Page >

Garmin 1040xs / B75M Transducer = Problem

Notices
Marine Electronics Forum

Garmin 1040xs / B75M Transducer = Problem

Old 09-29-2018, 11:16 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Apr 2005
Location:
Posts: 471
Likes: 0
Received 1 Like on 1 Post
Default Garmin 1040xs / B75M Transducer = Problem

I've got a Garmin 1040xs paired with a B75M bronze thru hull transducer on a Ameracat 27. The sonar had been working very well in all regards until in the middle of a fishing trip several weeks back it quit reading bottom. I was able to get an extremely faint return off the bottom in shallow water but not even enough that it would register the depth in the upper corner of the display.

I call Garmin Tech Support and went through all the various trouble shooting steps including software updates, returning the unit to factory default settings, etc. Nothing worked. Finally they asked me to go purchase an inexpensive plastic transom mount transducer, plug it into the head unit and drop it over the side to see if that worked. I followed those steps and sure enough I was getting a good image on the sonar and reading bottom just fined.

Based on that they determined my B75M transducer was bad and I purchased a new one ($800) and had it installed. I just got the boat back and although the sonar is able to mark bottom a idle speed the return is not nearly as good as it use to be when everything was functioning properly. The bottom line looks "soft" if that makes sense and the unit will not read bottom at cruise speed and goes in and out at anything over idle.

I've gone through the sonar set up functions and everything looks ok but the performance is just not what it should be.
Any ideas as to what could be going on? Bad head unit? How can I tell without buying another?

Thanks,
Old 09-29-2018, 11:30 AM
  #2  
Senior Member
 
Join Date: Jan 2012
Posts: 1,743
Likes: 0
Received 54 Likes on 51 Posts
Default

You need to find a dealer with a TDT1000 transducer tester.
Old 01-13-2019, 07:11 PM
  #3  
THT Sponsor Admiral's Club Member
THT sponsor
 
Join Date: Aug 2014
Location: Eastern Shore MD
Posts: 2,315
Likes: 0
Received 549 Likes on 313 Posts
Default

Did you ever figure anything out with this problem.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.