Notices
Marine Electronics Forum

2004 C120 Display problems

Old 07-08-2006, 06:36 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default 2004 C120 Display problems

Hey Guys - looking for some of the Raymarine C120 experts out there. Let me paint the picture. Dedicated cable running from a deep cycle battery (non-engine starting) through single pole pull switch (hot side) to power depth sounder module, radar scanner and C120 display.

Ran offshore this morning. Had engine charging deep cycle battery for 2 hours. After about 30 minutes of trolling, display started acting up like it was experiencing low voltage. Switched over to "both" on battery switch w/o no change. After being turned off for 30 minutes, display would come back on as normal for about 15 minutes and then act up. By acting up, I mean going black with moving black lines about 1/4" wide. Turned unit off for most of day. Would turn back on periodically and it would do the same thing.

Checked out electrical system when back at dock. 12.6 volts in the end of the power cable. Unplugged everything except the power cable, still doing it's funky black thing.

Any thoughts???

Thanks for the help!!!

Chris Miller
Mystic Islands, NJ
Old 07-09-2006, 09:54 AM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Dec 2003
Location: haines city, fl
Posts: 172
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

raymarine has great website that answers lots of stuff, or e-mail for direct answer. they have been great.
jim
Old 07-09-2006, 10:47 AM
  #3  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Feb 2005
Location: Kent Narrows, MD
Posts: 7,139
Received 772 Likes on 364 Posts
Default Re: 2004 C120 Display problems

I would disconnect the sounder & radar to eliminate them from the situation temporarily & see if the display will operate. If so, find the trouble. If not, time to call RM.

Check your power & ground connections carefully

I'm a big fan of having everything on a separate circuit for just this reason. Here is a recent project of mine that allowed everything to be on a separate circuit & be fused appropriately. There is a master switch that controls power to the fuse panel



Please report back

Old 07-09-2006, 12:28 PM
  #4  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

Elusive,

For "groans and smiles" (being PC), I disconnected everything from the display and with only the power cord plugged in, it did the same thing. Of course at the dock this morning, everything is peachy keen. I am going to have to turn it on and time how long it takes to act up and try to take a picture of the screen. It is pretty ugly looking.

Thanks for the info...

Chris
Old 07-09-2006, 03:58 PM
  #5  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Feb 2005
Location: Kent Narrows, MD
Posts: 7,139
Received 772 Likes on 364 Posts
Default Re: 2004 C120 Display problems

Chris - Let me clarify. I meant disconnect power to the radar & sounder that is shared with the display. I was hoping this might isolate the cause of the power problem (if that is what is causing the display to blank)

When the display blanks, check the LED on the sounder module to see if its on. If the GPS antenna is on the same switch, it has an LED also. If you have a DSM 300 sounder, they are notorious for power problems



Old 07-09-2006, 07:43 PM
  #6  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

The outher units are attached to the same lugs that feed the display, but when I put my multimeter probes in the end of the power cord for the display, I am reading 12.3-12.7 volts. I checked the unit last night before I covered up the boat for the night and it went right on. This afternoon, I pulgged the power cord in, turned on the switch and immediately was greated by this


It does not show up real good in the photos. I had the unit covered all day with a towel and it was sunny today, but I had the helm windows open. I am wondering if it is a heat issue, but it did not do this last season.

Chris Miller
Mystic Islands, NJ
Old 07-09-2006, 09:14 PM
  #7  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Nov 2005
Location: Annapolis, MD
Posts: 1,036
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

What version of software are you running? Have you upgraded your software to the latest release?
We did not have the exact problem as you but our C120k kept cycling on and off. We would turn it off for about 15 min, then turn it on and all would be well. RM Tech support told use to upgrade the software. We originally had version 1.21 and we upgraded to version 3.18.
We have been out 25miles or so twice since we upgraded (about 2 10hr trips) and it has not acted up, so we are hoping the upgrade fixed it.

Just a thought.
Kg
Old 07-09-2006, 09:28 PM
  #8  
Senior Member
 
Join Date: Apr 2006
Location:
Posts: 417
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

I really think it's a defective unit. That looks a lot like a loose LCD cable or bad display board.

It could also be some type of interference, but if it wasn't doing it last year I have a hard time thinking that's causing a problem this year. It's happening ot the entire LCD, so I'm willing to bet it's a head unit problem. Time to ship it back.

Old 07-10-2006, 09:41 AM
  #9  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

I sent Raymarine an email last night with these pictures, hopefully they will have an idea of what is wrong and give me some direction...I hate being w/o my unit for a few weeks, but if it isn't working, what is the difference??? I have 2 Garmin chart plotters in the boat as well, so I am set for navigation purposes, but a depth finder is an important piece of hardware....and tough to live w/o
Old 07-10-2006, 09:44 AM
  #10  
Senior Member
 
Join Date: Apr 2006
Location:
Posts: 417
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

CG when I had my screen replaced (scratched) in April it took less than 48 hours to get the unit back to my door. I'm not sure where you are, but if you are out of this zone (New England UPS) ship it overnight saver to them in NH, you'll probably have it back by Friday.

Old 07-10-2006, 09:49 AM
  #11  
Senior Member
 
Join Date: Apr 2006
Location:
Posts: 417
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

CG when I had my screen replaced (scratched) in April it took less than 48 hours to get the unit back to my door. I'm not sure where you are, but if you are out of this zone (New England UPS) ship it overnight saver to them in NH, you'll probably have it back by Friday.

Old 07-10-2006, 01:13 PM
  #12  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

Scott,


What did they charge you? I looked at the website and they listed a standard repair flat rate of $999 for a C120 multifunction display....that is a lot of cash to fork over...
Old 07-10-2006, 02:19 PM
  #13  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Oct 2004
Location: North Myrtle Beach SC
Posts: 8,045
Likes: 0
Received 1 Like on 1 Post
Default Re: 2004 C120 Display problems

Elusive - 7/9/2006 11:47 AM

I would disconnect the sounder & radar to eliminate them from the situation temporarily & see if the display will operate. If so, find the trouble. If not, time to call RM.

Check your power & ground connections carefully

I'm a big fan of having everything on a separate circuit for just this reason. Here is a recent project of mine that allowed everything to be on a separate circuit & be fused appropriately. There is a master switch that controls power to the fuse panel



Please report back
Can you take a picture of that open so I can see the whole thing. I am trying to figure out a better way to gain access to my electronics.
Old 07-10-2006, 09:24 PM
  #14  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

I packed it up and overnighted it to the service center. I will let you know what they come back with. I found out that the flat $999 was a maximum charge, not the min.
Old 07-10-2006, 09:59 PM
  #15  
Senior Member
 
Join Date: Apr 2006
Location:
Posts: 417
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

CG, I paid nothing as it was within the 1 yr warranty. I've had two units, the one on the other boat for about 18 months with no trouble, and the new one will be a year old next month. Both problems were self inflicted with me scratching the screens Otherwise no problems.

They'll likely fix it by Wednesday and I bet you have it back Thursday depending on what needs to be done and your participation. I was very pleased with the turnaround.

Old 07-14-2006, 11:20 AM
  #16  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

Guys,
I just got off the phone with Raymarine as I have been out of town most of the week. They received my display unit on Tuesday morning, it was shipped back to me on Wednesday with the upgraded software and a new diode in some board inside. Unfortunaly they could not get the unit to duplicate my symptoms (of course) after running on the bench for several hours.

Good news is that they performed the upgrades free of chrage under a warranty claim (2yr basic warranty) on an unregistered unit and one that they could not confirm the serial number on to determine date of manufacture. I guess they are striving for excellent customer service, which is expected on a $2500 unit. I will report back in when I get it back and start using it again.

Thanks again for the info!

Chris Miller
Old 07-14-2006, 02:11 PM
  #17  
Senior Member
 
Join Date: Apr 2006
Location:
Posts: 417
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

Chris so did they get it back to you overnight or is it still in process? They shipped mine back express. Can't beat that turnaround when you think of it, they had it Tuesday and it was back out the door Wednesday. Not even the great Furuno will do that.

If you get it back and it's still goofy you know it's either a bad wire on your boat or some other gremlin electrically. At least now the updates are done, and you barely lost a few days. Let us know how it turns out.

Old 07-14-2006, 08:50 PM
  #18  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Nov 2004
Location: Mystic Islands, NJ
Posts: 443
Likes: 0
Received 0 Likes on 0 Posts
Default Re: 2004 C120 Display problems

Scott,

There was no charge and they shipped it back DHL ground, which took 3 days from New Hampshire. I got it back this afternoon, hooked her up and left it on for over 3 hours. It appears to be fine now. They may have fixed something and do not want to tell me what it was. They claim to have updated the software (true) and replaced a diode with a larger one?? They did not give me any info on the diode thing. Maybe that was the problem. Bummer of it all is that they performed a factory reset and I lost all of my waypoints and custom screen settings. Oh well, small price to pay for them fixing the unit free of charge. I use my older Garmin as my primary navigation unit and it is still loaded with 7 years worth of waypoints. I can load ones into the Raymarine throughout the course of the summer.

Thanks again for the info!

Good Luck!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.