Notices
Marine Electronics Forum

JL Amp needs repair

Old 12-04-2017, 06:52 AM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jun 2012
Location: Georgia
Posts: 702
Default JL Amp needs repair

Does anyone know if I can ship an amp direct to JL? I have a new amp that made a pop first time powered up and now is dead. Their website says to have a dealer ship it in and I don’t have a dealer nearby. Thanks
Erobinson1 is offline  
Old 12-04-2017, 06:55 AM
  #2  
Senior Member
 
Join Date: Jul 2015
Posts: 457
Default

Call their customer service and get an RA number. Once you have this, you will ship the amp to their location in Arizona for repair.
Ianl931 is offline  
Old 12-04-2017, 08:36 AM
  #3  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jun 2012
Location: Georgia
Posts: 702
Default

Originally Posted by Ianl931 View Post
Call their customer service and get an RA number. Once you have this, you will ship the amp to their location in Arizona for repair.
Thanks 👍
Erobinson1 is offline  
Old 12-04-2017, 08:51 AM
  #4  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jun 2012
Location: Georgia
Posts: 702
Default

Can’t even find a ph number on their website. All I can find is that the return be made by a dealer. Anybody got a ph #?
Erobinson1 is offline  
Old 12-04-2017, 08:53 AM
  #5  
Senior Member
 
Join Date: Jul 2015
Posts: 457
Default

954-443-1100 ext 2551
Ianl931 is offline  
Old 12-04-2017, 11:31 AM
  #6  
Admirals Club Admiral's Club Member
 
Join Date: Aug 2016
Location: Palm Beach, FL
Posts: 198
Default

https://jlaudio.zendesk.com/hc/en-us...ervice-Options
DSeaVeeng is offline  
Old 12-04-2017, 01:21 PM
  #7  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jun 2012
Location: Georgia
Posts: 702
Default

Originally Posted by Ianl931 View Post
954-443-1100 ext 2551
Thank you.
Erobinson1 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread