Notices

Raymarine E120W and Radar set up

Old 12-02-2017, 09:43 AM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Apr 2005
Location: Cornelius, NC
Posts: 310
Default Raymarine E120W and Radar set up

Having issues with my E120W and a Raymarine open array. Someone in a previous thread mentioned that there may be two different types of Seatalk crossovers. Is this true. It keeps giving me the message: No seatalk HS connection detected on unit.
MidOcean is offline  
Old 12-02-2017, 11:45 AM
  #2  
Senior Member
 
Join Date: Jan 2012
Posts: 1,741
Default

I think you need E55060 crossover. I don't know of a different one. Are you sure the radar is powered up?
Amity83 is offline  
Old 12-03-2017, 06:50 AM
  #3  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Apr 2005
Location: Cornelius, NC
Posts: 310
Default

Originally Posted by Amity83 View Post
I think you need E55060 crossover. I don't know of a different one. Are you sure the radar is powered up?
There is no activity with the array. It's open.

Thanks

T
MidOcean is offline  
Old 12-03-2017, 06:51 AM
  #4  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Apr 2005
Location: Cornelius, NC
Posts: 310
Default

Yes. It's an E55060 Crossover
MidOcean is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread