Notices
Marine Electronics Forum

Mechanics HELP! Melted Engine Harness

Old 08-20-2017, 06:22 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2016
Location: Pompano Beach
Posts: 7
Likes: 0
Received 0 Likes on 0 Posts
Default Mechanics HELP! Melted Engine Harness

Ok so I just got a brand new boat fresh from the factory. It is a 25ft Center Console with a dual battery setup. After hooking up battery terminals I turned the battery switch on and turned the ignition key. Next thing you know I smell burning. After shutting off batteries I open console and find the engine harness melted along with a bunch of other wires. What happened?
Old 08-21-2017, 04:32 AM
  #2  
Senior Member
 
Join Date: Oct 2011
Posts: 186
Likes: 0
Received 25 Likes on 15 Posts
Default

call the factory-
Old 08-22-2017, 05:45 AM
  #3  
Admirals Club Admiral's Club Member
 
Join Date: Nov 2005
Posts: 707
Received 18 Likes on 15 Posts
Default

Picture, did you hook up the battery terminals: why not the dealer?
Old 08-22-2017, 01:27 PM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Feb 2003
Location: M.Vineyard, MA
Posts: 16,454
Received 996 Likes on 770 Posts
Default

Either battery connections or engine/ dash wiring connections hooked up wrong polarity? Or something in the harness was otherwise shorted to ground.

If it happens to be error at the batteries, hopefully your insurance will cover most of the repair. Otherwise it would seem to be under dealer warranty.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.