Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Reload this Page >

Having a problem with radar 4g hds-9 touch.Help please

Notices
Marine Electronics Forum

Having a problem with radar 4g hds-9 touch.Help please

Old 04-05-2015, 01:42 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Jul 2011
Location: north florida
Posts: 1,549
Default Having a problem with radar 4g hds-9 touch.Help please

I have a 9 month old lowrance 4g radar with hds-9 touch screen.Everything worked fine last time.Get there now and everything works but the radar.It says no radar.Not sure what to do.Anyone have a issue like this.TIA
lwpierrat is offline  
Old 04-05-2015, 03:50 PM
  #2  
Senior Member
 
Join Date: Mar 2015
Location: ct
Posts: 112
Default

Mine did same thing checked the wires and they were loose I had to tighten up the ground
nofluke48 is offline  
Old 04-05-2015, 09:12 PM
  #3  
Admirals Club Admiral's Club Member
 
Join Date: Sep 2003
Location: San Diego
Posts: 1,468
Default

In May of 2012 I purchased new a HDS10 and 4G radar and all worked fine until the end of 2014. The HDS would only intermittently recognize the 4G. Called Lowrance and they sent me a couple replacement cables that didn't fix the problem so they had me send the radome back to them and they sent me a replacement for free, even though it was out of warranty by 6 months. All works fine now.

Do a search for a thread I had on the 4G issue earlier this year. I just gave you the short version. From what I hear usually the most common problem is with loose wires in the com connector coming down from the radome. Good luck
greenno is offline  
Old 04-06-2015, 04:21 AM
  #4  
Senior Member
Thread Starter
 
Join Date: Jul 2011
Location: north florida
Posts: 1,549
Default

Thanks guys,Ill check into these issues.
lwpierrat is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread