Notices
Marine Electronics Forum

big issue with my garmin!

Old 04-04-2015, 12:30 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 8
Default big issue with my garmin!

i have the 198c and it worked fine when I first got the boat. sometimes I can turn it on and it will run flawlessly other ill turn the switch on and then hit the power button and it will turn on and the screen will fade out and shut off and sometimes it will beep. we thought it was a wiring issue but all wiring is good and the power cable caries 12.3v at the battery to the unit so that's not it.. we even ran separate wires from the battery to gps itself and it would turn on and the screen would stay bright and then just go black and beep... so idk whats going on here.
mhuffman is offline  
Old 04-05-2015, 06:45 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 8
Default

Nobody has had this issue?
mhuffman is offline  
Old 04-05-2015, 07:05 PM
  #3  
Admirals Club Admiral's Club Member
THT sponsor
 
InternationalMarineMike's Avatar
 
Join Date: Feb 2014
Posts: 8,336
Default

It is either a power issue or something internal that requires the unit to be serviced. I believe this unit was released about 10 years ago. It may not be worth fixing. See what Max from Max marine on here has to say. He deals in a lot of the older equipment and knows it inside and out.

Mike
InternationalMarineMike is offline  
Old 04-05-2015, 07:08 PM
  #4  
Admirals Club Admiral's Club Member
 
Join Date: May 2011
Location: Louisiana and Morehead City N.C.
Posts: 11,378
Default

Yea as old as that unit is probably not worth fixing. Plenty of good multi purpose units for good prices that will be way better than old technolgy.
captain28570 is offline  
Old 04-05-2015, 07:25 PM
  #5  
Senior Member
 
Join Date: Sep 2005
Location:
Posts: 763
Default

Years ago, I had a similar problem with a 182. The morning after some bad thunderstorms, the unit would not stay on. Sent it in and they said it was an internal relay, (bad) that keeps the unit powered on.
catch232 is offline  
Old 04-05-2015, 08:31 PM
  #6  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 8
Default

I was told it may be a relay. I will look into it. we are going to bimini in aug and I either wanted to fix this and have time for it to prove reliable or get a new one. im trying not to get a new one because money is going to be tight between now and the trip. were going with 3 other boats but for piece of mind I still want my main gps and a back up... you never know whats going to happen.
mhuffman is offline  
Old 04-05-2015, 08:33 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 8
Default

mike, do you know his user name?
mhuffman is offline  
Old 04-05-2015, 08:45 PM
  #8  
Admirals Club Admiral's Club Member
THT sponsor
 
InternationalMarineMike's Avatar
 
Join Date: Feb 2014
Posts: 8,336
Default

mstyle8517
InternationalMarineMike is offline  
Old 04-06-2015, 04:07 PM
  #9  
Admirals Club Admiral's Club Member
THT sponsor
 
Join Date: Jul 2010
Posts: 4,963
Default

Got your message. Sounds like a bad LVDS cable connection inside the unit. If the screen doesn't use an LVDS cable to connect to the main board, then it's not something we know how to fix. If you send it to me I can take a quick look and see if we can fix it, but I can't make any promises, I really make it my policy not to touch any Garmin stuff, but if I can fix it easily, why not.
mstyle8517 is offline  
Old 06-07-2015, 02:01 PM
  #10  
Junior Member
Thread Starter
 
Join Date: Apr 2015
Posts: 8
Default

i know this is kinda late but I did a factory reset on it and it has worked flawlessly since
mhuffman is offline  
Old 06-08-2015, 10:44 AM
  #11  
Senior Member
 
Join Date: Dec 2013
Location: CT
Posts: 191
Default

Originally Posted by mhuffman View Post
i know this is kinda late but I did a factory reset on it and it has worked flawlessly since
mhuffman - Let me know if the problem or any other problem returns. I may be able to help you out.
LosBandidos is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread