Notices
Marine Electronics Forum

Depth Finder not reading

Old 09-13-2014, 08:41 AM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Dec 2010
Location: SC
Posts: 440
Likes: 0
Received 7 Likes on 6 Posts
Default Depth Finder not reading

I have a Humminbird 788ci and for some reason the depth isn't showing. I went through some rough water yesterday and hasn't worked since.

I restored factory settings and nothing. It's not even showing a number where it should be.
Old 09-13-2014, 11:40 AM
  #2  
Admirals Club Admiral's Club Member
 
Join Date: Aug 2009
Posts: 12,327
Likes: 0
Received 291 Likes on 199 Posts
Default

Transducer ok?
Old 09-13-2014, 12:01 PM
  #3  
Admirals Club Admiral's Club Member
THT sponsor
Marine Advertiser
 
Join Date: Oct 2009
Posts: 22,418
Likes: 0
Received 1,438 Likes on 713 Posts
Default

ditto..check the dcuer..
Old 09-13-2014, 07:56 PM
  #4  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Dec 2010
Location: SC
Posts: 440
Likes: 0
Received 7 Likes on 6 Posts
Default

It looks fine
Old 09-15-2014, 05:52 AM
  #5  
Senior Member
 
Join Date: Oct 2013
Posts: 2,178
Received 468 Likes on 261 Posts
Default

Hello, is the boat out of the water? If so a little tip, turn on the unit for depth, put your ear under the transducer and listen for a faint "clicking", if you can hear it, the transducer is emitting, if not it might be not working, check the wiring to the unit (screen) for any loose connections. Hope this helps.
Old 09-15-2014, 09:05 AM
  #6  
Junior Member
 
Join Date: Jun 2009
Posts: 5
Likes: 0
Received 0 Likes on 0 Posts
Default

You say it stopped working after running through rough water. That makes me think that you may have lost good contact with the cable prongs in the base. This can happen with the quick connect bases. Try removing the head from the base, make sure each cable is seated well and not loose in the base and then reseat the head. If you are lucky, you only lost contact of one or more cables due to the jostling from the rough water.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.