Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Reload this Page >

Lowrance LCX-37c trouble with navionics card

Notices
Marine Electronics Forum

Lowrance LCX-37c trouble with navionics card

Old 09-09-2014, 08:36 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Feb 2011
Location: Houma, LA
Posts: 365
Default Lowrance LCX-37c trouble with navionics card

I recently purchased a used boat that has a Lowrance LCX-37c unit and it wasn't starting up so i removed the micro SD card from the Navionics card and it will work now. Question is can i get it to run with the 2GB micro sd card so that i can get the function of the Navionics card as the built in Lowrance maps leave much to be desired. Hell it doesn't even show the main bayou i leave from and shows me running through dry land till i hit open water The card seemed to be working when i sea trialed the boat....
Bayoudude is offline  
Old 09-09-2014, 08:44 AM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Mar 2002
Location: Elizabeth, Pa USA
Posts: 491
Default

I would take the whole card out and make sure that there isn't corrosion or anything on the contacts and then clean them just to be on the safe side. If it still does it after that, try to update the unit to most current update and see if that alleviates the problem.

Keith
threeriversmarine is offline  
Old 09-10-2014, 04:45 AM
  #3  
Senior Member
 
Join Date: Apr 2012
Posts: 363
Default

What Navionics card do you have?
KIrtH is offline  
Old 09-10-2014, 04:50 AM
  #4  
Senior Member
 
Join Date: Nov 2009
Location: Australia
Posts: 3,945
Default

Definitely clean the contacts on the card and the contacts in the head unit with electronics cleaner. If ypu are lucky, that will fix the problem.

If not, the card may have gone bad. Navionics may be able to help you with a replacement.
Moonlighter475 is online now  
Old 09-10-2014, 07:33 AM
  #5  
Senior Member
Thread Starter
 
Join Date: Feb 2011
Location: Houma, LA
Posts: 365
Default

It is the Navionics gold with 2GB micro sd card. From what i have been reading it seems the first place to start is seeing what software version i am running. After that it seems like i need to boot it up without the card then put it in and see if the unit will recognize it. I plan on trying this afternoon after work. The chip is listed as compatible with the LCX-37c on the Navionics website but i have read that these units have issues with the 2GB cards. It seemed to work for the previous owner and i know it was working when we sea trialed the vessel. The seller did make a copy of his way points the afternoon i bought the boat so I am not sure if that may have caused the problem.
Bayoudude is offline  
Old 09-11-2014, 11:54 AM
  #6  
Senior Member
 
Join Date: Oct 2006
Location: Michigan's U.P.
Posts: 224
Default

The card may be corrupt. Happened to me with a lakemaster card on a lcx27. Mine would have the map data for a while when powered up then would just beep and lose all chip data. Drive me crazy for a while thinking the unit was bad but when I got a new chip, voilà, it works again.
DooFighter is offline  
Old 09-26-2014, 12:48 PM
  #7  
Senior Member
Thread Starter
 
Join Date: Feb 2011
Location: Houma, LA
Posts: 365
Default

Still can't get this thing to work with the Navionics card. I have updated the lowrance software to the latest version 2.50. If i turn on the unit it boots up and then if i insert the navionics card i get an error message stating the the MMC format is not recognized. The contacts are all bright and shiny and i don't think that is the issue. If i try booting up the unit with the card installed it just turns off and never gets to the map screen. I also plugged the navionics card into my PC here at work and there are charts on it so the card shouldn't be corrupt if my PC sd card reader sees it fine. Also the card reader on the lowrance had no issue with the update from a standard 2GB sd card from wally world. I am at a loss.
Bayoudude is offline  
Old 09-26-2014, 01:01 PM
  #8  
Senior Member
 
Join Date: Apr 2012
Posts: 363
Default

Find another sonar to try the card in, if it doesn't work in another sonar then its probably the card if it does then its your sonar
KIrtH is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread