Notices

Radio Won't Turn On?

Old 09-04-2014, 05:02 PM
  #1  
Senior Member
Thread Starter
 
Join Date: May 2014
Location: Bowie, MD
Posts: 512
Default Radio Won't Turn On?

In may i installed a Dual MXCP43 head unit (non cd, detachable faceplate) and have had zero issues until yesterday. We used the boat saturday and played music just fine, yesterday I attached the head unit and it wouldnt turn on. I have power to the back of the unit and every wire is attached. Does this mean the radio is toast? Any thing i can try to save it?
greasemonkey54 is offline  
Old 09-05-2014, 02:55 AM
  #2  
Senior Member
THT sponsor
 
InternationalMarineMike's Avatar
 
Join Date: Feb 2014
Posts: 8,336
Default

Sound alike it may be toast. This is about $50.00 head unit and with that said the quality is probably just not there. You may be able to get it checked under warranty.

Here are a few things to look at prior to sending it in:

1. Yellow wire not connected or incorrect voltage. Needs to be between 11-16 volts.

2. Black wire not connected. This is your ground, make sure it is good.

3. Fuse may be blown. Check fuse. These units usually have a 10 amp inline at yellow wire.

4. If this does not work send it in.
InternationalMarineMike is offline  
Old 09-05-2014, 05:52 AM
  #3  
Member
 
Join Date: Aug 2014
Posts: 93
Default

Fuses, fuses, fuses. They'll get ya every time. Check that and the input voltage, as Mike said above, otherwise look at replacing the unit.
StripeRR HunteRR is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread