Notices

Garmin 740S Melted Chip

Old 09-02-2014, 06:09 PM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2011
Location: Coral Gables, Fl.
Posts: 2,900
Default Garmin 740S Melted Chip

My Garmin 740S was acting up yesterday ie.not powering up. Today I went to try to diagnose and after multiple checks it occurred to me to open the door where the chip goes. Smoke was emitted and i burned my finger pulling out the chip.. Once the chip was out the unit worked perfectly. I tried plugging chip back in and flashing white screen appeared and within a millisecond the chip got to 150 degrees.

I am kinda happy the unit works but obviously want my chip. Any ideas? Will Garmin take care of me?

Last edited by Searosis; 09-03-2014 at 05:59 AM.
Searosis is offline  
Old 09-03-2014, 07:32 AM
  #2  
CME
Admirals Club Admiral's Club Member
 
Join Date: Mar 2010
Posts: 3,839
Default

Holy smokes!


Sorry, I couldn't resist.

I'd call Garmin. I've never heard of that happening before.

Is it possible there was saltwater in there?
CME is offline  
Old 09-03-2014, 07:39 AM
  #3  
Senior MemberCaptains Club Member
 
Join Date: Mar 2002
Location: Elizabeth, Pa USA
Posts: 491
Default

I would venture a guess and say that there is a crazy short inside of the card reader, possibly saltwater as CME mentioned, or it could be corrosion. It could also be the chip itself, do you have an SD card that you could test out? Preferably an older one that if damaged won't really matter?

Keith
threeriversmarine is offline  
Old 09-03-2014, 11:23 AM
  #4  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2011
Location: Coral Gables, Fl.
Posts: 2,900
Default

Originally Posted by CME View Post
Holy smokes!


Sorry, I couldn't resist.

I'd call Garmin. I've never heard of that happening before.

Is it possible there was saltwater in there?
Highly unlikely that saltwater would get in there. It is under my hardtop and I almost always have my enclosures up. Only fresh water in that area. Next stop is garmin
Searosis is offline  
Old 09-03-2014, 11:29 AM
  #5  
Member
 
Join Date: Aug 2014
Posts: 93
Default

That's a lot of current going through a memory chip
StripeRR HunteRR is offline  
Old 09-03-2014, 12:17 PM
  #6  
Senior MemberCaptains Club Member Admiral's Club Member
THT sponsor
 
Join Date: May 2002
Location: Brookhaven, LI, NY
Posts: 15,755
Default

The little tiny, close together gold plated leads on the chip can loosen, and touch/short out. That is prolly what happened. I've shorted 2 SD chips over the years (both in a computer). But none of them smoked or caught fire, they just don't work anymore and a close look shows a small burn mark between two leads on the chip.
Birdman is offline  
Old 09-04-2014, 09:39 PM
  #7  
Member
 
Join Date: Jan 2008
Location: Norfolk,VA
Posts: 36
Default

Get some cheese, make nachos with the hot chips. MMMMMM Nachos......
nsgdoc is offline  
Old 03-13-2018, 10:26 AM
  #8  
Admirals Club Admiral's Club Member
 
Join Date: May 2017
Posts: 20
Default Same issue on garmin 741xs

Exactly samething happend to me on garmin 741xs. first it stopped showing the map thats on the SD, then the the sd threw some smoke and got pretty hot. Screen began flashing. remove the sd and everything is ok, just cant see the map obviously cause the sd is out. What was your solution?
arrivillagao12 is offline  
Old 03-14-2018, 04:40 AM
  #9  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Apr 2011
Location: Coral Gables, Fl.
Posts: 2,900
Default

Originally Posted by arrivillagao12 View Post
Exactly samething happend to me on garmin 741xs. first it stopped showing the map thats on the SD, then the the sd threw some smoke and got pretty hot. Screen began flashing. remove the sd and everything is ok, just cant see the map obviously cause the sd is out. What was your solution?
I never fixed it. Sold the boat with the unit. Disclosed issue to new buyer and he didn’t care.
Searosis is offline  
Old 03-14-2018, 06:12 AM
  #10  
Senior Member
 
Join Date: Jan 2012
Posts: 1,741
Default

I have a 10 month old Garmin G2 Vision chip get corrupted 2 years ago. The files got all messed up even though the chip was readable by PC. Garmin refused to offer any assistance, I had to shell out $300 for a new card.
Amity83 is offline  
Old 03-14-2018, 11:54 AM
  #11  
Senior Member
 
Join Date: Apr 2012
Location: Tierra Verde, FL
Posts: 308
Default

Curious...do you guys leave the card in all the time when not in use?
Grey_Beard is offline  
Old 03-15-2018, 08:02 AM
  #12  
Senior Member
 
Join Date: Jan 2012
Posts: 1,741
Default

Originally Posted by Grey_Beard View Post
Curious...do you guys leave the card in all the time when not in use?
Yes. I'm not worried about theft at my marina. I'm far more worried about be losing it than anything else, so I leave it in.
Amity83 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread