Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Reload this Page >

Sea Hunt 225 Ultra - Stereo shuts off and NSS8 Flickers when adjusting trim tabs

Notices
Marine Electronics Forum

Sea Hunt 225 Ultra - Stereo shuts off and NSS8 Flickers when adjusting trim tabs

Old 07-03-2014, 08:37 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Mar 2010
Location: Sharon, MA & Falmouth, Cape Cod
Posts: 306
Default Sea Hunt 225 Ultra - Stereo shuts off and NSS8 Flickers when adjusting trim tabs

Is this normal? This happen to anyone else?
Agoldsc is offline  
Old 07-03-2014, 09:07 AM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Dec 2001
Location: Mt. Pleasant, SC USA
Posts: 350
Default

It's not normal. You are seeing a voltage drop when using your tabs that is below spec for your radio and plotter. Could be a bad battery or bad ground connection. Does this happen with both tabs or only one?

It might help us if you tell us about your battery configuration and what type of trim tabs you have.
anothergirl is offline  
Old 07-03-2014, 09:11 AM
  #3  
Senior Member
Thread Starter
 
Join Date: Mar 2010
Location: Sharon, MA & Falmouth, Cape Cod
Posts: 306
Default

The batteries are new this year but I did take them out during the winter. I will check my connections.
It happens with both tabs and when I am pressing them one at a time. I will take a picture of my better set up and tabs this weekend.

Thanks for confirmation that this is not normal.
Agoldsc is offline  
Old 07-03-2014, 09:16 AM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Dec 2001
Location: Mt. Pleasant, SC USA
Posts: 350
Default

One other point, if you are using 'wing nuts' on your battery connections, get rid of them and use lock nuts.
anothergirl is offline  
Old 07-03-2014, 02:31 PM
  #5  
THT Sponsor
THT sponsor
 
Join Date: Jun 2014
Location: St. Petersburg, FL
Posts: 1,904
Default

Where is the power lead for the NSS 8 attached? By that I mean, is it attached to the same source as the trim tabs (i.e. circuit breaker/fuse, same buss connector)?
mahimahi99 is offline  
Old 07-03-2014, 05:28 PM
  #6  
Admirals Club Admiral's Club Member
 
Join Date: Nov 2010
Location: SC
Posts: 168
Default

Originally Posted by mahimahi99 View Post
Where is the power lead for the NSS 8 attached? By that I mean, is it attached to the same source as the trim tabs (i.e. circuit breaker/fuse, same buss connector)?
What he said
mavnkat is offline  
Old 07-07-2014, 02:58 PM
  #7  
Senior Member
Thread Starter
 
Join Date: Mar 2010
Location: Sharon, MA & Falmouth, Cape Cod
Posts: 306
Default

The NSS8 is running through the fuse in the dash. I am not sure how the tabs are connected.
Agoldsc is offline  
Old 07-08-2014, 11:42 AM
  #8  
Member
 
Join Date: Jun 2007
Location: Tallahassee, FL
Posts: 57
Default

I would guess that the Stereo, NSS8 and trim tabs are all connected to the same(source) wire, and when you utilize the trim tabs that it pulls more amps than the source wire can handle. Solution run a heavy gauge source wire from the battery to your circuit breaker/fuse/ buss.
chuck216 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread