Notices
Marine Electronics Forum

GARMIN 441s BAD?

Old 03-21-2014, 06:09 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Feb 2014
Posts: 25
Likes: 0
Received 0 Likes on 0 Posts
Default GARMIN 441s BAD?

I have a Garmin 441s with a hull mounted transducer. It was working fine about a two weeks ago on an offshore fishing trip and then on the way back in it stopped working. I tried all the usual suggested fixes after doing my research, i.e. making sure it was not kicked up and making sure all the connections were ok. After several reboots and restore to factory settings, I had no luck. The only image I would get was what appeared to be surface noise with no depth reading but I did get a water temp reading. The boat was taken out of the water for some repairs and the service tech said it was not the transducer that was the problem. I took the chartplotter to a knowledgable sales rep at Gander Mountain and he plugged it into a good transducer at which point the usual "clicking" noise was not heard from it. He plugged the same transducer into a good garmin chartplotter and we immediately heard the clicking noise indicating that it was the chartplotter that was bad. Does anyone have a known fix to this or am I stuck doing battle with Garmin trying to get it replaced or fixed under a warranty I am not sure exists due to the fact that the unit was bought used with the boat. I dont even have any of the receipts from the previous owner. Not sure I can even afford another unit anytime soon as the initial purchase of the boat and some costly repairs have taken up all of my funds. Maybe an old school sounding stick is more my price range right now!
Old 03-21-2014, 07:52 PM
  #2  
Admirals Club Admiral's Club Member
 
Join Date: Jul 2011
Location: South FL
Posts: 1,360
Received 46 Likes on 22 Posts
Default

Go hassle Garmin, and don't stop until you get a new (or fixed) unit. When I email Garmin for help with my plotter (which just so happens to be a 441 as well) they are always prompt in replying and very nice.
Old 03-24-2014, 11:28 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Feb 2014
Posts: 25
Likes: 0
Received 0 Likes on 0 Posts
Default firmware update...

I spoke to a garmin rep via email and he pointed out that the firmware should be updated. Upon preparing the SD card for the update I noticed the update was released on 03/06/14 and coincidentally my chartplotter stopped working on 03/08/14 when we were underway. I will try to do the update as soon as I get the boat back from repair. The only thing I am trying to figure out is how a firmware update make the sonar stop working. Anyone have any ideas/experience with this one?

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.