Notices
Marine Electronics Forum

yamaha tach problem

Old 08-02-2005, 07:14 AM
  #1  
Member
Thread Starter
 
Join Date: Jul 2005
Location: s.w. florida
Posts: 39
Likes: 0
Received 0 Likes on 0 Posts
Default yamaha tach problem

I have a 97 yamaha tach that just went nuts on me the other day? the numbers all look funny and I cant read it any more? i have 2 tachs but only one is doing this. any ideas? do i need to replace it and if so is it easy todo? and do i have to get one for a 225hp? any help would be great thanks..
Old 08-02-2005, 10:33 AM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Jul 2002
Location: Sarasota, FL
Posts: 1,414
Likes: 0
Received 1 Like on 1 Post
Default RE: yamaha tach problem

replace it....no way to service them. They corrode internally. I presume this is the multifunction guage.

Yamaha has changed the guage slightly....and the new ones have brighter orange paint than the old ones. You might want to buy an older one on ebay rather than just buy a new one that won't match (that's what I did). Actually they have made three versions of the guage....so check that the one you are buying is of the right vintage...the very old one looks very different. Do not worry if the model number is somehow different than what you think you should be buying. Often the model number indicates which cable comes with the unit in the box...and you don't need a new cable, so it doesn't matter.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.