Notices
Marine Electronics Forum

Garmin Temp Probe Problem

Old 07-21-2005, 12:02 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Mar 2002
Location: Boston, MA
Posts: 138
Likes: 0
Received 0 Likes on 0 Posts
Default Garmin Temp Probe Problem

Last year, I bought a temp probe to go with my 168MAP Sounder. Worked fine last season but now it's acting funny. Reads air temp correctly but as soon as it hits that water I get very high readings. Yesterday I was cruising in 65-70 degree water and it was reading 130-150 degrees. When I pulled the boat at the end of the day it read 90 which was the air temp at the time.

I am going to upgrade my fishfinder at some point so I don't want to buy a new one which is what Garmin said my one option was. I may still be under warrantee but have since lost my receipt so I can't prove it.

Any thoughts on how I could try to fix this?
Old 07-21-2005, 12:51 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Feb 2005
Location: Houston
Posts: 1,167
Likes: 0
Received 0 Likes on 0 Posts
Default Re: Garmin Temp Probe Problem

If you paid with a credit card your account history will have the info needed to replace other wise send it to Garmin and let them test it ...

John

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.