Notices

Lowrance update for Elite 7

Old 09-19-2013, 07:57 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Jul 2010
Location: Hudson Valley,NY
Posts: 590
Default Lowrance update for Elite 7

did the latest update bring the tide info back ? any confirmations ? what other improvements from the update have you noticed ? Thanks.
BoatlessInNY is offline  
Old 09-19-2013, 10:44 AM
  #2  
Senior Member
 
Join Date: Mar 2009
Location: Cruisin easy street on mud tires!
Posts: 1,495
Default

There is a while thread dedicated to the newest 2.0 update. Cliff notes...its good.
davlan88 is offline  
Old 09-19-2013, 05:03 PM
  #3  
Senior Member
THT sponsor
 
captain nate's Avatar
 
Join Date: Sep 2010
Location: Bradenton Florida
Posts: 8,503
Default

in terms an idiot can understand (me) how do you do an update?
captain nate is offline  
Old 09-20-2013, 06:06 AM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Mar 2002
Location: Elizabeth, Pa USA
Posts: 491
Default

Basically you download the update from Lowrances website and then unzip the file into an empty SD card and put it into your unit while its off. It will update automatically and let you know when its done and take out the SD card. For an Elite-7 though, make sure that you put it on a microSD card.

Keith
threeriversmarine is offline  
Old 09-20-2013, 09:38 AM
  #5  
Senior Member
THT sponsor
 
captain nate's Avatar
 
Join Date: Sep 2010
Location: Bradenton Florida
Posts: 8,503
Default

The unit needs to be OFF?
captain nate is offline  
Old 09-20-2013, 11:05 AM
  #6  
Senior Member
 
Join Date: Jun 2010
Location: Idaho/Mississippi
Posts: 1,411
Default

Nate

I am pretty sure you have to have the unit off before you put the card in. Insert the card THEN turn the unit on and it should auto update and let you know when its finished. Then turn it off, remove the card, insert your mapping card and you are good to go. Just turn it on the next time you head out.
ifsteve is offline  
Old 09-20-2013, 12:13 PM
  #7  
Senior MemberCaptains Club Member
 
Join Date: Mar 2002
Location: Elizabeth, Pa USA
Posts: 491
Default

Originally Posted by nate. View Post
The unit needs to be OFF?
I apologize, I thought that I mentioned to turn it on after putting the card in.

Keith
threeriversmarine is offline  
Old 09-20-2013, 12:17 PM
  #8  
Senior Member
 
Join Date: Jun 2010
Location: Idaho/Mississippi
Posts: 1,411
Default

Originally Posted by threeriversmarine View Post
I apologize, I thought that I mentioned to turn it on after putting the card in.

Keith
Keith,

You did. My buddy is a bit slow on the uptake.
ifsteve is offline  
Old 09-21-2013, 03:25 PM
  #9  
Senior Member
THT sponsor
 
captain nate's Avatar
 
Join Date: Sep 2010
Location: Bradenton Florida
Posts: 8,503
Default

I'm not very technologically advanced.
captain nate is offline  
Old 09-22-2013, 04:34 PM
  #10  
Senior Member
 
Join Date: May 2013
Location: Eugene, OR
Posts: 422
Default

Davlan 88,

"There is a while thread dedicated to the newest 2.0 update. Cliff notes...its good"

What is a "while" thread? Maybe WHOLE thread? Where? I did a search on this website and found nothing but this thread.

I have been waiting semi-patiently for months now for the "imminent" update that would fix the missing tide data. In fact, I logged on here specifically to see I there had been an update or to start a thread to yank Lowrance's chain again on this issue.

I see there is an update...Yay! But the update notes make NO MENTION of re-activating the tide data........hmmm.

I have downloaded the update but am not able to get to my boat and the unit for awhile.

Can you confirm specifically.....the update enables the tide data???

Thanks,
Peter Patricelli
peterpatricelli is offline  
Old 09-25-2013, 02:08 PM
  #11  
Senior Member
 
Join Date: May 2013
Posts: 882
Default

Yes, the Elite 7 2.0 update did correct the tide bug.
Todd Driscoll is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread