Notices

JL- MHD AMP-problems?

Old 08-09-2013, 04:37 PM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: Jul 2011
Posts: 489
Default JL- MHD AMP-problems?

Anybody have any issues with their MHD amps? I have had mine(mhd900/5) for two years and have had to send it back to Jl 2x (just past the one year mark and then again a few weeks ago)? I got the red/green flashing error light and no explanation of the problem when i got it back. I had the m600/6 for a few years and never had an issue. Switched to the MHD bc it was supposed to draw less power.
Just curious what everybody else's experience has been.
JointAsset is offline  
Old 08-09-2013, 04:45 PM
  #2  
Senior Member
 
Join Date: Jul 2004
Location: S Fla
Posts: 23,400
Default

4.5 yrs on my MHD's- no problems...
Glen E is offline  
Old 08-09-2013, 05:09 PM
  #3  
Senior MemberCaptains Club Member
 
Join Date: Feb 2006
Location: BILOXI, MS
Posts: 1,483
Default

I have lost both an MHD 750/1 and a MHD 600/4 in that last three years. JL took care of the 600/4 under warranty.

Last edited by Biloxi Regulator; 08-14-2013 at 04:33 AM.
Biloxi Regulator is offline  
Old 08-14-2013, 07:24 PM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Feb 2006
Location: BILOXI, MS
Posts: 1,483
Default

How much was it to get the amp repaired? I have a 750/1 I would like to get repaired and JL has been unresponsive to my emails.....
Biloxi Regulator is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread