Notices
Marine Electronics Forum

Northstar 6000i brightness issues

Old 07-21-2013, 07:09 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2010
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default Northstar 6000i brightness issues

Hi all -
I have a Northstar 6000i who display is very very dim. I turn the brightness all the way up, but I can still barely see the nav chart and the other screens are as good as black. Does anyone know if there is some other way to adjust the brightness beside by hitting the power key once?

Thanks

John
Old 07-21-2013, 10:03 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Feb 2003
Location: M.Vineyard, MA
Posts: 16,446
Received 996 Likes on 770 Posts
Default

On p. 8 of your manual, it explains to adjust brightness hit the power key once, THEN use the cursor to adjust brightness up. Is that what you did? It sounds like you... may... have neglected to follow up with the cursor adjustment.

http://www.northstarnav.com/upload/N...nual_Rev_D.pdf

It also noted if the unit is too hot the brightness will adjust downward automatically but you can override that by adjusting brightness again in normal fashion above. Covering the top and back of the unit with a reflective material may prevent that issue.

I'd expect their might be other available display modes such as Night pallete and Super-Brite (that washes out most color though, so "Normal" is generally much better) the N/S 952X series offer, but I don't see similar Mode option mentioned in the manual.

If none of that helps, you may have a failing screen and should be able to find help with that at Max Marine Electronics or Marine Electronics of the Outer Banks (MEOB.)
Old 07-22-2013, 07:22 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Mar 2010
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default

I have the manual. Thanks. I did that I could barely see the level of brightness going up on the screen. Its still very, very dark. I thought it could be a night mode, but it seems the clock is correct. Thanks for the help. I hope it is not the screen going bad.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.