Notices

Loosing fishfinder display

Old 03-02-2013, 07:24 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 5
Default Loosing fishfinder display

I have a Raymarine C80 and I am loosing fishfinder display intermittently. All connections appear to be secure. Is this a ground issue? Can I attach a busbar to my battery terminal to improve ground connections? Thanks.
Mrdarn is offline  
Old 03-02-2013, 08:03 AM
  #2  
Admirals Club Admiral's Club Member
THT sponsor
Marine Advertiser
 
Join Date: Oct 2009
Posts: 21,659
Default

Your first post....welcome!

Are you having the same problem with the chart function?..or just sonar?
And does the whole unit shut down?

Are you connected directly to your battery?
semperfifishing is offline  
Old 03-02-2013, 08:37 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 5
Default

The charting is working good, It's just the depth, bottom display of fishfinder. It drops displays dashes on depth finder until it works again.
Mrdarn is offline  
Old 03-02-2013, 08:58 AM
  #4  
Admirals Club Admiral's Club Member
THT sponsor
Marine Advertiser
 
Join Date: Oct 2009
Posts: 21,659
Default

Originally Posted by Mrdarn View Post
The charting is working good, It's just the depth, bottom display of fishfinder. It drops displays dashes on depth finder until it works again.
I would look at your transducer as possibly being the area of concern.
semperfifishing is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread