Notices
Marine Electronics Forum

Garmin 5212 Help Needed!!!!!

Old 07-11-2012, 05:44 AM
  #1  
Senior Member
Thread Starter
 
Join Date: Apr 2008
Location: st.augustine,fl
Posts: 1,209
Default Garmin 5212 Help Needed!!!!!

Ok, i did the search thing and couldnt come up with what i am experiencing.

I have 2 5212's at the helm flush mounted in the console dash and a 4212 up top in the tower.
The 2 5212's will power up but both have lines running thru them as well as the pages keep shifting/moving from left to right. I can select charts/sonar/etc on them and they will go to that screen but they will not register any info and still have the lines going across the screens. After a couple seconds, they will just freeze up and will not allow me to make any selections.
The 2 5212's and the 4212 up top are all interfaced and connected. The 4212 up top works fine.
Has anyone experienced this before? What are the odds that both 5212's are having the exact same problems at the exact same time? This all happened the same day about a week ago.
I am fishing the Ancient City King Fish Tourny this weekend and desperately need help. Can anyone offer any insight as to what i should do or what i can try?
I have already removed the connections from the back of the units and made sure they are clean and tight.

Thanks for all your help. Sorry for the long post
904polarized is offline  
Old 07-12-2012, 01:03 PM
  #2  
Admirals Club Admiral's Club Member
THT sponsor
 
Join Date: Mar 2009
Location: Fort Myers, Fl
Posts: 1,755
Default

How do you have this system set up? Are you running it through a network port or a nmea2k back bone? It seems almost that youre two 5212's arent interfaced with anything.

pictures would help!
veikx is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread