Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Reload this Page >

Comnav 1420 Autopilot Computer Overheating?

Notices
Marine Electronics Forum

Comnav 1420 Autopilot Computer Overheating?

Old 07-07-2012, 11:57 AM
  #1  
Admirals Club Admiral's Club Member
THT sponsor
Thread Starter
 
Join Date: Jul 2010
Posts: 4,958
Default Comnav 1420 Autopilot Computer Overheating?

I wanted to see if anyone here knows any more about these things than we do. We parted out a 1420 system and the customer who bought the computer is upset with us because it overheated and burned out. Says its his 3rd one that's done this and that he's got fans on his 4th one and so far so good. Blames it on Florida.

I theorized that perhaps his motor/drive was trying to pull too much juice out of these computers, maybe the wire gauge he's using is too thin, or that he's just the unluckiest guy in the world, but that it's not anything we've done wrong and that perhaps he needs to change systems to something more heavy duty or go after Comnav.

What's the good, the bad, and the ugly with these things? Has anyone heard of this happening on this particular unit? Is this the DSM300 of autopilots or are we getting jerked around here?

Last edited by mstyle8517; 07-07-2012 at 06:36 PM.
mstyle8517 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread