Notices

Furuno NavNet System Problems. Selling?

Old 10-17-2011, 06:49 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2011
Location: South West Florida
Posts: 9
Default Furuno NavNet System Problems. Selling?

I recently purchase a boat with a Furuno NavNet system. I know nothing about this system. The radar works and so does the navigation but the sounder is just a blue screen. The previous owner replaced the "black box" last year when the sounder stoped working for him. So here are my questions...

1. how do I diagnose the problem?
2. Is the system worth fixing?
3. Can this item be refurbished? (screen, trackball)
4. Would anyone buy the used system and approximately how much is it worth?

Thank you in advance for any replies.
rbifi is offline  
Old 10-17-2011, 07:14 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Oct 2005
Location: Brisbane, Australia
Posts: 587
Default

Turn it on.

Seriously.

Go to the roto-dial and select high freq transduce
Red_Tag is offline  
Old 10-17-2011, 07:26 PM
  #3  
Admirals Club Admiral's Club Member
 
Join Date: Feb 2010
Location: Boynton Beach, FL
Posts: 1,826
Default

Which Nav Net we talking about here? vx1 vx2 or 3d?
laythewood is offline  
Old 10-17-2011, 07:27 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Mar 2011
Location: South West Florida
Posts: 9
Default

You can assume I know how to turn it on and select the sounder. I would appreciate some real help! I was told this is the site to come to for help! Seriously!
rbifi is offline  
Old 10-17-2011, 07:34 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Mar 2011
Location: South West Florida
Posts: 9
Default

laythewood, it is the vx1.

Thanks.
rbifi is offline  
Old 10-18-2011, 06:03 AM
  #6  
Admirals Club Admiral's Club Member
 
Join Date: Jun 2008
Location: Plymouth Ma.
Posts: 8,036
Default

Check the sounder module to see if the status light is on
CMEBoston is offline  
Old 10-18-2011, 03:42 PM
  #7  
Admirals Club Admiral's Club Member
 
Join Date: Apr 2006
Location: Morehead City, NC
Posts: 1,099
Default

Call Furuno and ask for tech support. They will walk you through it. That's what I would do.
buzzk is offline  
Old 10-18-2011, 03:45 PM
  #8  
Admirals Club Admiral's Club Member
 
Join Date: Jan 2009
Location: dix hills ny
Posts: 4,034
Default

Originally Posted by buzzk View Post
Call Furuno and ask for tech support. They will walk you through it. That's what I would do.
They can help you very fast!!! They are great!!!
blackfinmike is offline  
Old 10-18-2011, 04:12 PM
  #9  
Senior Member
 
Join Date: Aug 2007
Location: Miami, FL
Posts: 215
Default

Originally Posted by rbifi View Post
I recently purchase a boat with a Furuno NavNet system. I know nothing about this system. The radar works and so does the navigation but the sounder is just a blue screen. The previous owner replaced the "black box" last year when the sounder stoped working for him. So here are my questions...

1. how do I diagnose the problem?
2. Is the system worth fixing?
3. Can this item be refurbished? (screen, trackball)
4. Would anyone buy the used system and approximately how much is it worth?

Thank you in advance for any replies.
1. Make sure that all of the connections are secure and look to see what the status light on the sounder is doing.
2. If there is something wrong with the sounder and it is only a year old, I would say yes, it is worth fixing. Furuno equipment is usually rock solid, so you will still get a lot of use out of this equipment.
3. You would have to have a Furuno dealer look at it or, send it in to Furuno, but yes they can fix that stuff.
4. ????

Have you tried posting these questions on Furuno's forum page on their web site? It might be worth a try to see what they have to say. Here's a link: http://www.furunousa.com/Support/Forum.aspx

Good luck!
Justin
Justin009 is offline  
Old 10-19-2011, 09:41 AM
  #10  
Admirals Club Admiral's Club Member
 
Join Date: Apr 2006
Location: Morehead City, NC
Posts: 1,099
Default

When I have had to send things back to Furuno, I always sent it direct to Furuno not through a dealer. Depending on shipping it's never taken more than a week or two to get it back.
buzzk is offline  
Old 10-19-2011, 06:44 PM
  #11  
Senior MemberCaptains Club Member
 
Join Date: Aug 2002
Location: Surfside Beach, TX, USA
Posts: 2,471
Default

Originally Posted by Justin009 View Post
3. You would have to have a Furuno dealer look at it or, send it in to Furuno, but yes they can fix that stuff.

Have you tried posting these questions on Furuno's forum page on their web site? It might be worth a try to see what they have to say. Here's a link: http://www.furunousa.com/Support/Forum.aspx
Short story:
I trusted a dealer to analyze and repair the problem I was having with my Furuno component, and it took three weeks and $700 to get it working and back to me.
Had I shipped it direct to the Furuno Warranty department, it probably would have been one or two weeks and $30 (shipping cost).

If you can take it out, provide a note of what isn't right, and ship it to Furuno... They will take good care of you.
savage is offline  
Old 10-20-2011, 05:05 AM
  #12  
Admirals Club Admiral's Club Member
 
Join Date: Jun 2008
Location: Plymouth Ma.
Posts: 8,036
Default

Do you really think Furuno would fix it for free if its out of warranty? and if it is in warranty and you went to an authuorized Furuno dealer the Labor should have been paid by Furuno to the Dealer.....
CMEBoston is offline  
Old 10-20-2011, 04:12 PM
  #13  
edk
Admirals Club Admiral's Club Member
 
Join Date: Aug 2001
Location: Ft. Lauderdale, Florida
Posts: 1,090
Default

Originally Posted by CMEBoston View Post
Do you really think Furuno would fix it for free if its out of warranty? and if it is in warranty and you went to an authuorized Furuno dealer the Labor should have been paid by Furuno to the Dealer.....
It's not unusual for Furuno to do courtesy warranty repairs after the warranty expires. They replaced the bezel on my Navnet 1 1833C 6 years after I bought it. They did a software update on both of my networked displays and shipped them back to Florida 2nd day air on their dime.

Ed
edk is offline  
Old 10-20-2011, 04:58 PM
  #14  
Admirals Club Admiral's Club Member
THT sponsor
 
Join Date: Aug 2006
Location: Beach Haven/Collingswood, NJ
Posts: 459
Default Call first

Furuno customer service is top shelf.
I would call them first. It could be any number of fixable things such as incorrect jumper placement.
Get the S/N off your transducer cable [ determins jumper placement in the black box] in addition to all of the ID's from your components before you call.
They may recommend a dealer in your area if the problem cannot be fixed over the phone.
I had a problem that was a combination of bad set up by the installing dealer and a hardware malfunction. They spent about 8 hours over three days on the phone. Finally had a dealer replace the black box. There equipment works great when set up properly and will be worth the effort.
Captjohn22 is offline  
Old 10-21-2011, 05:35 AM
  #15  
Junior Member
Thread Starter
 
Join Date: Mar 2011
Location: South West Florida
Posts: 9
Default

Thanks for everyones help! I will work on it this weekend and let everyone know what I find. I hope it is a quick fix!
rbifi is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread