The Hull Truth - Boating and Fishing Forum

The Hull Truth - Boating and Fishing Forum (
-   Marine Electronics Forum (
-   -   Raymarine E120 key problem (

justskip 10-07-2011 08:31 PM

Raymarine E120 key problem
Hey Guys,
I'd thought I give you all a shot at my problem. I have a E120 that has been updated to v5.52, which didn't help this problem.
When I first turn on the machine, the first screen asks me to push the OK button. Which I do, but it takes several times, pushing the OK button, for the screen to pass. After I get to the main screen and push the data button the setup screen comes up and it takes several times on pushing the cancel button for the screen to pass. The main buttons that I am having trouble with are the OK, Cancel and the Data buttons. It's as if the CPU is crashing or has a virus.

I have no history on the machine as I bought it on EBay, and if it is a simple fix, I'll keep it. If not I will have to contest it thru PayPal and get a refund.

Any help would be appreciated.

The bezel is off and when I push a key the unit beeps, so I can assume that the keys are not stuck and are working (mechanically).


fishon3434 10-07-2011 08:40 PM

Have you tryed doing a factory reset on the unit

justskip 10-07-2011 08:52 PM

yes, thru the menu. It will not work with the first soft key at power on.

fishon3434 10-07-2011 09:20 PM

thru the menu is not the factory reset that is a default reset.

this is how to do a factory reset
  1. Press and hold down the first soft key (next to the power button.) while pressing the pwr softkey
  2. Keep holding the soft key down while the display reboots. A "Factory Reset" countdown will be displayed. Keep holding the first soft key until the countdown is complete.
  3. The display should reboot into normal operating mode.

Group27 10-08-2011 05:47 AM

I have an E80 and E120. There were running different rev levels so I thought to upgrade them to ver 5.52. After upgrade, I had the same problem that justskip is reporting. I brought it to the attention of Raymarine and they couldn't give me an answer. They did however give me a copy of ver 4.29. After "downgrading" to 4.29, the problem went away. It seems that there must have been an incompatibility between my E120 and the the latest software release (hardware rev, firmware version, etc.).

All I know is that the software downgrade did fix my problem.

justskip 10-08-2011 07:38 AM

Fishon3434, the unit will not do a factory reset using the first soft key. The soft keys seem to have a mind of their own. I was able to do a factory reset thru the menu, via the settings and data reset option. This did not solve the problem.

Group27, I downgraded to v4.29. Still the same problem.

The bottom row of soft keys including the OK and Cancel and the Data key seem at different times have a mind of their own or it takes several times for the key to do it function. At first boot up, the first screen I need to press the OK key, when I do so I can see the map screen zooming in every time I press the OK key. Until the first screen finally passes.

Any other thoughts?

Thanks again,

justskip 10-08-2011 08:22 AM

Problem solved
I tried the factory reset using the soft key again. But this time I pushed the key several times before holding it in while powering up. IT WORKED!!!!

Just wanted to say thank you to all for your help in brainstorming this problem.

Thanks again,

All times are GMT -7. The time now is 03:21 PM.

Powered by vBulletin® Version
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.