Notices
Marine Electronics Forum

Lowrance Customer Support

Old 09-07-2011, 11:47 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2011
Posts: 14
Default Lowrance Customer Support

I was in the market for a ff/gps/chart plotter. I really liked the Lowrance HDS but was a little scared because of all of the posts I read about really bad customer service.
I took my chances and bought the HDS-5.

Worked great for 2 weeks, then it started randomly losing the bottom. Made it really hard to fish as it would just come and go as it pleased.
After trying everything, I emailed Lowrance, thinking in the back of my mind "here we go"

I emailed them the Friday before Labor Day so even with good customer service, I did not expect to hear back from them until late the following week.

About as expected time wise, I heard back from them today. Not at all as expected the reply to my email was just asking me for my address etc and they said they would get a new transducer out to me.

Maybe they were bad in the past, but I honestly could not have asked for anything more. I did email them with everything I tried and apparently that was sufficient for them.
Personally, this is the kind of customer service that keeps me coming back.

I was sort of on the edge about buying the LSS-1 and then at some point in the future, getting the HDS-8. No more on the edge. I will be ordering one as soon as I get back from Florida (fishing trip to Cape Coral).

We always hear the bad about companies - well here is some good.
I give them a 2 thumbs up.
donberry is offline  
Old 09-10-2011, 08:18 PM
  #2  
Junior Member
 
Join Date: Aug 2010
Posts: 19
Default

Tried calling Lowrance Canada and just got voice mail. Gave my name and number for a return call and have not heard back as of 4 days ago. Will try again on Monday. I am having the same problem of loosing bottom. This is when the boat is stationary. Power down and turn back on still takes another couple of minutes to find bottom. I bought a Airmar b60 thinking that the 83-200 was the problem but still having issues. Hope to hear from someone soon.
Charlie415 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread