Notices
Marine Electronics Forum

Raytheon SL72 radar, no scan on display

Old 09-03-2011, 01:28 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2011
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Raytheon SL72 radar, no scan on display

I have an SL72 that has been in service 1998 and it has been working fine. Yesterday when the scan was turned on, there was no display. I shutdown the unit,turned the source power off, disconnected the cable from the display and replaced it to be sure it had not worked itself loose.Power back on, then I turned the unit on again. No error messages on the screen. I looked at the self test results and there were none marked as failed.

Correction: I missed that the line "Magnetron Heater " indicated FAIL.
Looks like the scanner needs work or replaced.

I will look for a reasonably priced replacement. Scanner product code M92678.

Thanks for any help.

Cal

Last edited by CalD; 09-05-2011 at 11:46 AM. Reason: Add info

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.