Notices
Marine Electronics Forum

Lowrance Sonic Hub Speaker Issue.....

Old 08-26-2011, 12:52 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Oct 2010
Location: Hahnville, La
Posts: 28
Likes: 0
Received 0 Likes on 0 Posts
Question Lowrance Sonic Hub Speaker Issue.....

Hello All,

Okay, this makes no sense. When listening to FM stations, I get sound out of both speakers.

However, when I listen to Anything else, Satillite Radio, iPod, etc. the sound only comes out of the left speaker.

I told Lowrance about the problem and they sent me a new Sonic Hub. Great! Hook it up, same problem.

The only thing left is the rather professional looking connection from the wire harness to the speakers. Next step would be to rewire that, but with the left speaker working during FM it is just driving me crazy.

Has anyone else had this issue?

Thanks and I hope everyone has a great weekend.

Last edited by BobbyLand; 08-26-2011 at 12:52 PM. Reason: Right/Left was wrong.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.