Notices
Marine Electronics Forum

Northstar

Old 08-25-2011, 07:56 AM
  #1  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: May 2010
Posts: 158
Likes: 0
Received 8 Likes on 2 Posts
Default Northstar

I had a 951 and recently replaced it as the screen got burnt over time from being left in the sun without a cover, but I haven't been able to get my old waypoints off of it. Does anyone know who to contact or how to get the old numbers off? The unit still powers up, but given the screen being shot, I can't read anything.

I don't care about fixing the screen or trashing the unit at this point, I just want to get my waypoints off of it before I throw it away.

Last edited by pnuttuf; 08-25-2011 at 08:18 AM.
Old 08-25-2011, 08:13 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Feb 2003
Location: M.Vineyard, MA
Posts: 16,467
Received 1,000 Likes on 773 Posts
Default

I recently pulled the WPs and routes from my 952s using Northstar's Waypoint Loader freeware. http://www.northstarnav.com/Downloads/

Many people use GPS Utilility but I haven't tried that one yet.

I used the program in my notebook attached to the boat powered 952 via Northstar's 1100-LC loader cable (not free) and a serial to USB adapter . (No serial port on my notebook.)

Unfortunately, I can't clearly recall whether it was simply a matter of pressing the 952's ON button at the appropriate time in the process, or if I had to wait to let the self-test screen play out , then "press any key" to accept and move beyond the disclaimer acknowledgement page. I think just On . The program suggests you can make the loader cable but you might check with Navico or the old Northstar dealers to see if you can still purchase one.

But are you pretty sure it is just the screen and not the power or SW boards? Also ....you did try adjusting the 951's contrast control on the left side , yes ? Sorry, just askin', as adjusting that the wrong way will definitely make the screen look like it is burnt or gonzo and I've seen owners overlook that before. .
Old 08-28-2011, 10:47 AM
  #3  
Admirals Club Admiral's Club Member
Thread Starter
 
Join Date: May 2010
Posts: 158
Likes: 0
Received 8 Likes on 2 Posts
Default

Yeah, I tried a bunch of different deal, and also got some help from another THT member but apparently my internal battery is bad too, so the waypoints i believe are gone for good.

Thanks for your suggestions and advice!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.