Notices

Garmin/GSD20 Fish finder problems

Old 11-08-2004, 01:18 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Mar 2002
Location:
Posts: 2,369
Default Garmin/GSD20 Fish finder problems

Have installed the Garmin GPS with the GSD 20 and the bronze tri-ducer.

Worked great for over a year, have a problem with the unit not finding the bottom, if I up the gain manually it will find it but with noise. The 50khz screen is good, but the 200 has some noise. Also the temp now seems off by 10 degrees.

No growth on transducer, connections look clean. Any suggestions for testing/checking would be apprieciated.
marlinmike is offline  
Old 11-08-2004, 02:29 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Jul 2002
Location: Sarasota, FL
Posts: 1,414
Default RE: Garmin/GSD20 Fish finder problems

Certainly sounds like a transducer problem. Have you checked the transducer connection to the GSD20 for corrosion? If not, can you borrow another transducer and mount it temporarily as a shoot thru the hull mount (put it on a bag of water) just to test out the GSD20.
Think Tweiss is offline  
Old 11-08-2004, 04:19 PM
  #3  
Senior MemberCaptains Club Member
 
Join Date: Mar 2002
Location: LINDENHURST, NY
Posts: 1,775
Default RE: Garmin/GSD20 Fish finder problems

I would agree with Think Tweiss. Something in the connection (either end) . Have you grounded or hit bottom by any chance?
Big E is offline  
Old 11-09-2004, 11:25 AM
  #4  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Mar 2002
Location:
Posts: 2,369
Default RE: Garmin/GSD20 Fish finder problems

Thanks for your input. Have not hit anything or grounded. Will double check the GSD20 unit.... Given the temp is off also seems some type of resistance is at play here... Thanks again.
marlinmike is offline  
Old 11-09-2004, 10:38 PM
  #5  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Aug 2004
Location: All over the place
Posts: 1,070
Default RE: Garmin/GSD20 Fish finder problems

I was thinking the ducer may be mounted behind a strake...
Wahzoo is offline  
Old 11-10-2004, 04:51 AM
  #6  
Senior MemberCaptains Club Member
 
Join Date: Mar 2002
Location: LINDENHURST, NY
Posts: 1,775
Default RE: Garmin/GSD20 Fish finder problems

Do boats grow strakes after a year in the water?
Big E is offline  
Old 11-12-2004, 10:12 AM
  #7  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Mar 2002
Location:
Posts: 2,369
Default RE: Garmin/GSD20 Fish finder problems

FYI follow up:

OK cleaned all connections on terminal strip and the connectors on the GSD 20, no change. Garmin says to do a low level reset, of course this will wipe out all my waypoints, but worth a try, I guess, if that doesn't do it they say its the transducer....
marlinmike is offline  
Old 11-15-2004, 09:38 AM
  #8  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Mar 2002
Location:
Posts: 2,369
Default RE: Garmin/GSD20 Fish finder problems

Did the ole RESET as instructed, NO good, looks like the transducer.
marlinmike is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread