Notices
Marine Electronics Forum

Lowrance X107c Sounder Locks Up

Old 06-14-2010, 04:51 AM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jan 2005
Location: Asheville, NC
Posts: 6,574
Received 291 Likes on 175 Posts
Default Lowrance X107c Sounder Locks Up

My buddy is on his third unit. All of them freeze or lock up. It isn't networked to anything. The only thing connected to it is the skimmer ducer and the black/red goes to a buss bar with an inline fuse. A voltmeter reads 14 volts on the pin going into the unit.

He is sitting down at the beach with no sounder for the third year in a row. Any ideas??

Thanks,
HH
Old 06-14-2010, 07:19 AM
  #2  
Senior Member
 
Join Date: Jul 2007
Location: Virginia
Posts: 128
Likes: 0
Received 0 Likes on 0 Posts
Default

Replace/try another transducer.
Old 06-14-2010, 08:04 AM
  #3  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Jan 2005
Location: Asheville, NC
Posts: 6,574
Received 291 Likes on 175 Posts
Default

Originally Posted by JayDee View Post
Replace/try another transducer.
I guess that is all that is left. You would think after returning the unit two times, Lowrance would have thought of this.
Old 06-16-2010, 05:41 PM
  #4  
Senior MemberCaptains Club Member
 
Join Date: Jul 2005
Location: easley sc
Posts: 1,942
Received 65 Likes on 48 Posts
Default

funny i got a 107 sitting in my office that did the same thing....

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.