The Hull Truth - Boating and Fishing Forum

Go Back   >

Thread Tools Search this Thread
Old 05-15-2010, 06:15 PM   #1
Senior MemberCaptains Club Member
Thread Starter
Join Date: Jul 2003
Location: Boston, MA
Posts: 101
Default Northstar M121 won't boot up

Any advise? When I turn on unit it the screen lights up to startup screen but does not completely turn on. It goes blank and then begins to start up again over and over. it will not shut off just keeps repeating process.
phestaris is offline   Reply With Quote
Old 05-15-2010, 07:16 PM   #2
Senior Member
Join Date: Aug 2005
Location: New England
Posts: 4,817

With the easy stuff first, is the power button, or any button for that matter, stuck in?

Voltage going to the unit?, batteries charged/amps all there?, connections-wiring to the unit/fuse-block?
thundra is offline   Reply With Quote
Old 05-16-2010, 01:46 PM   #3
Senior Member
Join Date: Mar 2005
Posts: 236

Press and hold the menu key and then press power to start up (keep holdong menu)
You should get a menu up that you wouldnt have seen before (let go of menu key now), go to RAM clear and execute. See if that makes a difference.
saltyseadog is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off

Forum Jump

All times are GMT -7. The time now is 05:38 AM.

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to and affiliated sites.

Powered by vBulletin® Version
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.