Notices
Marine Electronics Forum

THis is really strange.

Old 07-03-2009, 07:40 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Sep 2006
Posts: 200
Likes: 0
Received 1 Like on 1 Post
Default THis is really strange.

I have another thread on this original problem but I wanted to know what your ideas were on this new twist. My Garmin 498c had the backlight on the screen go out and I sent it in for replacement. I got the new , rebuilt one in and tried it out today. After 10 minutes the backlight went out again. Is this just an incredible coinsidence or is there something causing this? It really is just positive and negative. My voltage today was showing normal. How could this happen? I tried to call Garmin today but it was the day before the holiday and they were closed.;?
Old 07-03-2009, 08:18 PM
  #2  
Senior Member
 
Join Date: Jun 2009
Location: Central Jersey
Posts: 375
Likes: 0
Received 2 Likes on 1 Post
Default

sounds like your dumb luck

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.