Notices
Marine Electronics Forum

lowrance gps signal lost

Old 10-12-2008, 08:27 AM
  #1  
Member
Thread Starter
 
Join Date: Jan 2008
Location: mass
Posts: 31
Default lowrance gps signal lost

I have a lcx 28c hd unit Yesterday i lost the gps signal on the unit , couldn't get it to work the rest of the day. does anybody have a clue of whats wrong or how i can fix it? would appreciate the help thanks
drezend is offline  
Old 10-12-2008, 01:47 PM
  #2  
Senior Member
 
Join Date: Feb 2007
Location: landlocked in New Mexico
Posts: 1,757
Default Re: lowrance gps signal lost

There are multiple power leads and fuses and all of them need to be working properly this is a common issue. Make sure the
small ground wires are all making a good connection too. Next check the NEMA 2000 connections. I would also note whether
the time is correct, and whether it was receiving any of the satelites on the satelite page. This may help you decide whether
you were having an antenna problem or power problem feeding the antenna.


Steve
jenkinsph is offline  
Old 10-12-2008, 04:16 PM
  #3  
Member
Thread Starter
 
Join Date: Jan 2008
Location: mass
Posts: 31
Default Re: lowrance gps signal lost

thanks for the advice, i will definetly try it out
drezend is offline  
Old 10-13-2008, 06:18 PM
  #4  
Junior Member
 
Join Date: Oct 2008
Location: Golden Valley, AZ
Posts: 24
Default Re: lowrance gps signal lost

The nmea 2000 network which is what your gps is hooked up to has it's own fuse.
lorenbennett is offline  
Old 10-23-2008, 02:30 PM
  #5  
Junior Member
 
Join Date: Oct 2008
Location:
Posts: 1
Default Re: lowrance gps signal lost

I don't want to highjack your thread but I am having the same issue. Any clue where that fuse might be? I have determined that my head unit is putting out 12v but at the end of the network cable that connects to the GPS module there is not 12v. Would it be a bad cable or a blown fuse on that cable?
Big Knots is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread