The Hull Truth - Boating and Fishing Forum

The Hull Truth - Boating and Fishing Forum (https://www.thehulltruth.com/index.php)
-   Marine Electronics Forum (https://www.thehulltruth.com/marine-electronics-forum-19/)
-   -   RL70 radar problems (https://www.thehulltruth.com/marine-electronics-forum/191599-rl70-radar-problems.html)

marine electrician 10-05-2008 01:19 PM

RL70 radar problems
 
Have a customer with a raymarine RL70. The radar displays a ring in close proximity to the boat. The shorter you bring the range, the larger the ring appears. In close range < 1/4 mile, almost the entire screen is this ring. Raymarine has not been helpfull at all. Anyone with any ideas.

Hewesfissher 10-05-2008 04:32 PM

Re: RL70 radar problems
 
How about saving waypoits and doing a master reset? Sometimes these pesky customers mess with stuff that I cannot figure out. If it's (the problem) is NOT software related, a new, clean slate is a nice way to get them back up. JMO....

Birdman 10-06-2008 09:41 AM

Re: RL70 radar problems
 
Somethng on the boat reflecting?? Outriggers bouncing off each other and back to dome......... I had the RL70 for 8 or 9 years and loved it. I would get a ring every once in a a while as with any radar unit, but it would only be temporary (few seconds). You've obviously turned down the gain, and checked the "FTC" settings, right?

MarineTechnician 10-06-2008 07:44 PM

Re: RL70 radar problems
 
If the problem is environmental you'll see side lobes.

If the display shows a ring on every sweep, and not a sun, adjust the timing. You can adjust the ring so it almost completely goes away. Be careful that the adjustment does not cause short distance targets to get sucked into the centre.

If you turn the gain to 100% do you have lots of speckle? Does the screen completely fill in? If so the MIC and front end are ok. If not the MIC, or IF strip are bad.

Look at the total TX+standby hours. If the number approaches 5000 hrs then I'd suspect the maggy. If you have one on the shelf throw it in, or check the heater voltage in the scanner. if the problem doesn't go away then most likely it's the modulator strip.

Hope this helps
MT


All times are GMT -7. The time now is 05:05 AM.

Powered by vBulletin® Version 3.9.3.7
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.