Notices

Just got a Garmin 535S DEAD....

Old 04-26-2007, 07:10 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Apr 2005
Location: michigan
Posts: 244
Default Just got a Garmin 535S DEAD....

I just got my order from worst marine.... long story..

I had a 198c that failed
(sonar cuts with tx of radio issue dealt with it for 2 years had west marine ext warrantee and could not be fixed)


I returned it to worst marine and they gave me a credit of $805.00 for it.


So the Fed EX truck arrives with the new garmin 535s...

I get ready to install it and I test it on the workbench before hand...

works for about a minute ... then the screen pops and nothing..

dead unit. the side green lights work but nothing out of the screen or no beeps

I called Garmin they said to hold select and power button to restart the unit... nothing happens
they said to hold Home and power nothing happens dead unit.




I got to send it back for another one, I am posting this to let others know there may be a possible screen issue.
I hope this is a random just my luck failure but we will have to see.

After being burned by Garmin for the 198c sonar cuts out issue never being properly fixed but ignored.

I am just glad that I opted for the five year warrantee.

bill
billnuts is offline  
Old 04-26-2007, 08:43 PM
  #2  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Jul 2004
Location:
Posts: 7,797
Default RE: Just got a Garmin 535S DEAD....

Bill ..... what was your power source??
bluewaterpirate is offline  
Old 04-26-2007, 09:33 PM
  #3  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Apr 2005
Location: michigan
Posts: 244
Default Re: Just got a Garmin 535S DEAD....

normal battery with fuses... 13.2 volt

sits on the bench running the radio for the garage. on a trickle charger

I disconected everything else before hook up

the side green button lights will light up upon pressing the power button

that indicates the unit is getting power inside.

the outside inline power fuse is ok.

but the screen will no come on and thier is no warm up beep.

bill

Just got a bad one i hope.

billnuts is offline  
Old 04-26-2007, 09:42 PM
  #4  
Senior MemberCaptains Club MemberPLEDGER
 
Join Date: Jul 2004
Location:
Posts: 7,797
Default Re: Just got a Garmin 535S DEAD....

Was it grounded .... by this I mean a ground strap from the negative battery post to a ground source?

Tom
bluewaterpirate is offline  
Old 04-26-2007, 10:13 PM
  #5  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Apr 2005
Location: michigan
Posts: 244
Default Re: Just got a Garmin 535S DEAD....

the ground is connected to the metal of the workbench.
the workbench is mounted to the wall

its the same bench I used for years to repair electronics for years.

it has anti static mats with wrist straps..

this was a hardware failure, I am going to get another unit by Wednesday at the latest,

I will keep you posted.

bill
billnuts is offline  
Old 04-27-2007, 01:11 AM
  #6  
Junior Member
 
Join Date: Mar 2007
Location:
Posts: 2
Default RE: Just got a Garmin 535S DEAD....



geno_1 is offline  
Old 04-27-2007, 01:25 AM
  #7  
Senior Member
 
Join Date: Oct 2006
Location:
Posts: 125
Default RE: Just got a Garmin 535S DEAD....

When you get the new unit you should update to the new software it corrects alot of issues.

http://www8.garmin.com/support/downl...ls.jsp?id=3519

Tron_1
tron_1 is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread