Notices

Lowrance LCX-19c problem?

Old 04-22-2007, 08:41 AM
  #1  
Member
Thread Starter
 
Join Date: Apr 2007
Location: Long Island sound
Posts: 33
Default Lowrance LCX-19c problem?

Last season I started having promlems with my LCX-19c reading bottom & marking fish. The unit would flash erroneous depths & wouldn't hold bottom unless I had the sensitivty manually set up to 97%. Also the unit refused to work at all on the 200khz & barely worked at 50khz. The transducer was a 50/200 transom mount skimmer which Lowrance replaced for me in 2005 for free even after warranty was up for 2+ years. I checked the angle of the transducer(& tried changing it to no avail). I called tech support & was told that it was probably the transducer. I purchased a 200khz 20 degree wide angle since most if not all of my fishing is done in less than 60' of water. I ran cable yesterday & before I connected the new T/D, I turned on the unit with the old T/D so that I could change the frequency to 200khz for the new T/D. I noticed that the old T/D emmitted what I would call a strange clicking pattern. It would emmit 6 quick clicks followed by a 1-2 second pause, then 2 slower clicks, another pause & then repeat. I connected the new T/D & got the same pattern. I never really paid attention to this when the unit was working right. I thought it used to emmit a steady clicking so I'm not sure if this is normal or perhaps there is a problem with the unit itself. The boat stays in a slip for the season & I would like to not have to haul it out to change the T/D again. I believe Lowrance upgraded the software back in 05 when I sent the unit in for service. Also what would be the normal sensitivity setting for 40' in salt H2O? Is there any sort of a reset or fresh start for this unit that I could perform myself if there is a problem or do I have to send the unit in?

Thanks for any input,

-time2fish
time2fish is offline  
Old 04-22-2007, 05:51 PM
  #2  
Senior Member
 
Join Date: Feb 2005
Location: Norway
Posts: 13,922
Default Re: Lowrance LCX-19c problem?

It seem as you have a problem with your unit, you should hear a steady clicking sound.

The only way I know how to do a full reset of everything in your unit would be by downloading the software again.
At 40' with the 200kHz skimmer transducer 87-91% sensitivity should give a good picture.'
abbor is offline  
Old 04-22-2007, 09:38 PM
  #3  
Member
Thread Starter
 
Join Date: Apr 2007
Location: Long Island sound
Posts: 33
Default Re: Lowrance LCX-19c problem?

Thanks abbor,
I have a email into Lowrance to get their take on this too. It seems to me like the unit is in some sort of test mode with that clicking pattern. That's why I asked about doing a reset. I'll wait for a reply from Lowrance before I do that.

Thanks again,

-time2fish
time2fish is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread