Go Back  The Hull Truth - Boating and Fishing Forum > BOATING FORUMS > Marine Electronics Forum
Reload this Page >

lowarance fuel flow sensor questions it quit ??

Notices

lowarance fuel flow sensor questions it quit ??

Old 04-16-2007, 02:15 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2006
Location: marysville wa
Posts: 1,033
Default lowarance fuel flow sensor questions it quit ??

it used to work perfect on my 200ocean pro

first it was wrong with the new opti but now it just quit working

i had water in fuel does that affect it ?

or mabey when they changed lines on repower could they have done something ?

lugger is offline  
Old 04-16-2007, 10:45 PM
  #2  
Senior MemberCaptains Club Member
 
Join Date: Dec 2005
Location: Round Rock, Tx.
Posts: 392
Default Re: lowarance fuel flow sensor questions it quit ??

Do you know if it's still in there after the repower? It's possible that they put it in backwards if they had it removed from your line.
I think you can run a system check for bus devices on your display, this should tell you if the network is even recognizing the fuel flow sensor.
kinggetter is offline  
Old 04-17-2007, 11:38 PM
  #3  
Senior MemberCaptains Club Member
 
Join Date: Nov 2002
Location: Pensacola, Fl
Posts: 11,168
Default Re: lowarance fuel flow sensor questions it quit ??

It has to be behind the fuel filter (between the filter and engine) and is direction sensitative. I'll bet that they either put it in backward, or it got debris in the turbine. Take a look.
thataway is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread