Notices

loran c coupler troubleshooting

Old 04-14-2007, 11:26 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2006
Location:
Posts: 2
Default loran c coupler troubleshooting

Anyone know how to troubleshoot a loran c coupler? I assume a resistance test would be the first thing to check, don't know what the reading should be. The coupler in question is for an Apelco DXL6500. I just bought the unit from e-bay.
cbozeman is offline  
Old 04-15-2007, 09:53 AM
  #2  
Senior Member
 
Join Date: Mar 2006
Posts: 833
Default Re: loran c coupler troubleshooting

grab a mulitmeter put it on the K ohm scale, positive to the center pin of the BNC, negative to the outer body of the BNC should read between 1.5K-2.1K ohms if the coupler is OK. If not, get the generic replacement from Gem, since I doubt raymarine has any, since they sent me to Gem 3 years ago for the same coupler that went to my dad's 6350.
SeaSwirler23 is offline  
Old 04-15-2007, 11:24 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Mar 2006
Location:
Posts: 2
Default Re: loran c coupler troubleshooting

Thanks for the info, did what you suggested and got a reading of .03 ohms, figured the coupler was shorted. Started wiggling the connector and got 1.6K ohms; found that the connector was shorted. will purchase a new one tomorrow.
cbozeman is offline  

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread