Notices
Marine Electronics Forum

furuno 1833 radar/sounder problems

Old 03-25-2007, 05:04 PM
  #1  
Senior MemberCaptains Club Member
Thread Starter
 
Join Date: Sep 2005
Location: Lafayette La
Posts: 3,596
Likes: 0
Received 44 Likes on 27 Posts
Default furuno 1833 radar/sounder problems

The other night while out fishing I had some issues with my furuno unit. I seemed to be having some battery problems due to one bad battery that night. I kept having to switch my perkos to the ALL position to get one of the motors cranked after having it killed for a while. What was happening was while I was using the gps to navigate (lining up the bearing numbers), I would click the radar on. Once the radar kicked on, the gps bearing would lock up and quit navigating. So I could not run the radar and the gps at the same time. It is an all in one unit. This is a major problem for running at night because I always like to navigate with the radar running in the dark. I think it could have potentially been due to weak batteries that could not run them both at the same time???? Any help would be appreciated

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.