Notices
Marine Electronics Forum

Lowrance LCX 20

Old 03-18-2007, 06:32 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2004
Location:
Posts: 23
Likes: 0
Received 0 Likes on 0 Posts
Default Lowrance LCX 20

Last trip unit worked great all day. The weather truned bad and we really got bounced around on the way home....My Gps worked fine all the way until about 2 miles from home and the unit said (gps module not responding). I have looked at all the connections and rewired one but still will not lock up....Did a cold start and still nothing. Some of the things I have read is it could be a power problem to the antenna...Has anyone had this happen and do you have any advise...

David ;?
Old 03-19-2007, 10:42 AM
  #2  
Senior MemberCaptains Club Member
 
ScarabChris's Avatar
 
Join Date: Jul 2005
Location: Dania Beach, FL
Posts: 28,413
Likes: 0
Received 43 Likes on 40 Posts
Default Re: Lowrance LCX 20

That has happened to me with my Lowrance GPS. It usually happens when I am near a big boat with a large open array radar going.

Though something very strange happened to me while out Saturday night at about midnight. While cruising through Port Everglades In Ft Lauderdale my GPS suddenly told me I was off the coats of Venezuela. I shut the unit off and on a few times and it still said I was in Venezuela. The next day it was fine.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.